Snapshots are failing, I'm getting different errors

When trying to run a complete snapshot on the site it failed at 78%, while processing the plugins folder, and it retuned this error:

“An unknown response returned from Snapshot backup attempt. Aborting. Double check Snapshot settings.”

Then I tried to run a snapshot including only the media files, and I got this other error right after starting it:

“The server is temporarily unable to service your request due to maintenance downtime or capacity problems. Please try again later.”

I was able to create a snapshot including only the databases and wp-config.php and .htaccess files, but it’s failing if including the media.

I’m running PHP 7.0.32, max_execution_time is set to 300, memory_limit to 1024M and enabling WP_DEBUG returned no errors.

  • Konstantinos Xenos

    Hi Kia !

    It seems that the server is running into I/O errors after a while since the zip reaches a bigger size than it can handles.

    To 'bypass' this I've split up the backup process into 2 different jobs. If you'll see your Snapshots now you'll have 1 named Media_Files ( this only includes the /uploads/ folder basically ) and one named WP_DB_Themes_Plugins ( this includes Plugins, Themes, Database, wp-config ).

    I've run some tests and this setup doesn't seem to be having any issues since it's completed way faster as the media files that are the 'heavy load' here are processed alone.

    You can replicate the settings by inspecting the above backups and add them to any location/automation you like.

    Tell us if you need further help!

    Regards,
    Konstantinos

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.