Snapshots fails on files

Hi Guys,

I'm currently having some issues with your snapshots plugin and am a little stumped on what to do next to rectify this issue. What is happening is that every time I run the backup process it will fail on the files. This is a live website and the aim is to provide them with a monthly backup direct into their dropbox account.

Looking at some other threads here I have attempted some of the suggestions with no luck, those are:

Checking the memory limit (Set at 256m).
Checking the max execution time/input time and max input vars (180, 180 and 5000 respectively).
Narrowing down the failure - it always seems to be on the files.
Checking any caching on this website I have found Varnish on our host, I have tried turning that off with no avail.
Checking the permissions with filezilla also show 0644 for files and 0755 for folders.
Checking the logs also show no errors (in snapshots/_logs/xxx.txt).

The only message I seem to get is this:
An unknown response returned from Snapshot backup attempt. Aborting. Double check Snapshot settings.

The only other point I can think of is it something to do with our hosting company? I haven't contact them yet but they are Smart / Best Web hosting https://www.bestwebhosting.co.uk/

Here is the server info for this website as I know this will be helpful:

The following table shows version information about your server. When contacting support it might be helpful to provide this information along with your specific issues.
WordPress Version 4.5.3
PHP Version 5.4.45
MySQL Version 5.6.30
Is Multisite No
WP_CRON Snapshot uses WP_CRON to run automated backups. If you have disabled WP_CRON via your wp-config.php you will not be able to schedule snapshots.
WP_CRON Enabled.
WP_CRON Lock timeout: 60
Folder Permissions Writable (0755) – /wp-content/uploads/snapshots
Writable (0755) – /wp-content/uploads/snapshots/_backup
Writable (0755) – /wp-content/uploads/snapshots/_locks
Writable (0755) – /wp-content/uploads/snapshots/_logs
Writable (0755) – /wp-content/uploads/snapshots/_restore
OpenSSL The OpenSSL Apache module is require to make secure connections with destinations like Dropbox and Amazon AWS.
OpenSSL installed
cURL cURL is used when connecting to remote destinations like Dropbox and Amazon AWS.
cURL installed
Version: 7.36.0
SSL Version: OpenSSL/1.0.1e
Libz Version: 1.2.3
Protocols: dict, file, ftp, ftps, gopher, http, https, imap, imaps, ldap, ldaps, pop3, pop3s, rtsp, scp, sftp, smtp, smtps, telnet, tftp
PHP runtime information
Display Errors Off
Error Reporting 4983 - E_ERROR, E_WARNING
Magic Quotes Off
Max Execution Time (seconds) 180 The value displayed can be adjusted by Snapshot PHP scripts.
Memory Limit 256M - WP_MEMORY_LIMIT defined by WordPress wp-config.php.
256M - WP_MAX_MEMORY_LIMIT defined automatically by WordPress
Open Basedir Off
Safe Mode Off
ZLib Compression Off

Thanks in advance for your help, hopefully we can get this sorted quickly.