snapshots fails to send files to S3

When configuring snapshot to export backups to amazon the export always fails.

This is what happens when I configure an amazon destination:

Upon providing my Access Key ID and Secret Access Key, snapshot successfully connects to amazon. I can tell this because the field ‘bucket name’ list is automatically populated.

However, when I click on ‘Test Connection’ the output looks like this:

Connecting to AWS

Using SSL: Yes

Setting Region: US Standard (s3.amazonaws.com)

Using Storage: Standard

Using ACL: private

Sending file to: Bucket: sunilwilliams-general-backups: Directory: Error: Send file failed :403 :

It looks like the connection fails.

If I save the destination details anyway and provide them to a snapshot configuration, the snapshot will save but will not be exported to amazon.

  • Tyler Postle
    • CGO

    Hey Sunil,

    Hope you're doing well today!

    Looks like you have a permissions issue happening here. I've taken a screenshot of my s3bucket permissions, can you make sure yours match that?

    If it's still happening after that then can you do a plugin conflict check by deactivating all other plugins, especially a security plugin if you have one.

    Look forward to hearing back on this!

    All the best,

    Tyler

  • Sunil
    • WPMU DEV Initiate

    Hey Tylor.

    I’ve replicated those permissions and I’m still unable to run a successful test.

    I’ve tried this with three different site across two hosts. All have similar plugin sets. Turning off wordfence doesn’t help.

    At this point I don’t want to mess too much with plugins across the sites. So extensive testing will have to wait.

    What does work without difficulty is sending files to greenqloud. I’d be happy to stick with that, but greenqloud have announced that they are closing their service. They will shut down direct access to customers by October. (this is the reason why I’m moving to amazon)

    When I get time I’ll test exports to amazon with plugins turned off.

  • Hive Minder
    • Design Lord, Child of Thor

    I’m having a similar issue for my site hosted on WP Engine.

    The S3 settings are definitely correct because Snapshot can connect to S3, navigate to the correct folder in the correct bucket and save the test file in that folder. The plugin successfully generates the backup zip file but it never gets uploaded to S3. Please help.

    Thanks,

    Mike

  • Sunil
    • WPMU DEV Initiate

    Just gonna notify that I haven’t resolved this either.

    I’ve tried again a couple of times and I get exactly the same results: S3 settings appear to be correct and reflect what Tyler has in his image. But I still get a 403.

    I don’t know whether I’m doing something wrong on the s3 end or within Snapshot.

  • Tyler Postle
    • CGO

    Hey Sunil and Mike,

    I’ve just set this up again on my WP Engine sandbox and it still sent the snapshot successfully. @mike, does your log file also give a 403 eror?

    It sounds like the issue is likely S3 side, but just in-case could both of you grant support access?

    You can grant support access from your admin via: WPMU DEV > Support > Support Access > Grant Access.

    Then I can compare the 3 of our setups and see if there are any differences on the WP end of things :slight_smile:

    Look forward to hearing back!

    Cheers,

    Tyler

  • Hive Minder
    • Design Lord, Child of Thor

    Hi Tyler,

    Nope, it doesn’t look like I am getting a 403 error. I have granted support access to the site. Do you need to know the site domain? If so, do you have an email address or DM I can send that to? It’s a client’s site so I don’t really want to be broadcasting that kind of information :slight_smile:

    Thanks,

    Mike

  • Tyler Postle
    • CGO

    Hey Mike,

    Sorry for the delay here. Yes the domain would be helpful :slight_smile:

    You can send it to me through our private contact form: https://premium.wpmudev.org/contact/

    Select “I have a different question” for your topic – this and the subject line ensure that it gets assigned to me :slight_smile:

    Send in:

    Subject: “Attn: Tyler Postle

    -domain

    -link back to this thread for reference

    -any other relevant urls

    If you could re-grant the access too that would be awesome.

    Talk to you soon!

    Cheers,

    Tyler

  • Sunil
    • WPMU DEV Initiate

    Hi Tyler.

    I’ve returned to this issue.

    I’ve set up Snapshots on suzannejamiesonselmo.com and I’ve granted Support Staff Access.

    Could you take a look at that and see if there’s anything I can do on the WordPress/Snapshots side?

    Thanks.

  • Sunil
    • WPMU DEV Initiate

    I think I’ve solved the issue.

    I generated a new access keypair within Amazon.

    In Snapshots I edited the destination using the new keypair.

    Testing, I don’t get a 403.

    I’ll run a snapshot and see what happens…

  • Hive Minder
    • Design Lord, Child of Thor

    Hi Tyler,

    Sorry for the delay in reply. I’ve been a bit bogged down in work lately. Anyway, I have just sent you the information via the contact form as per your request. Please can you have a look and get back to me.

    Many thanks,

    Mike

  • Tyler Postle
    • CGO

    Hey Mike,

    Thanks for sending the details in. Since we know the issue is that it’s not able to upload such a large file over to S3, this is likely a server restriction.

    I see your max post file size is 100mb can you try increasing that larger than the snapshot file size. Add this to your .htaccess:

    php_value post_max_size 150M
    php_value upload_max_filesize 150M

    We’ll increase max upload filesize just in-case too.

    You can also make those changes in your php.ini if you prefer:

    post_max_size 150MB
    upload_max_filesize 150MB

    Hope this helps and let us know if this does the trick :slight_smile:

    All the best,

    Tyler

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.