Snapshots not showing up

When I create a snapshot on my test site, they don't appear under the default folder /snapshots.

  • Katya Tsihotska

    Hi Julius

    Hope you had a good day!

    I tried to check your site, but I wasn't able to connect to your site via FTP. Could you please check your credentials and send me correct credentials through our contact form https://premium.wpmudev.org/contact/#i-have-a-different-question using this template:

    Subject: "Attn: Katya Tsihotska"
    - FTP credentials (host/username/password)
    - cPanel credentials (login URL/username/password)
    -link back to this thread for reference
    -any other relevant URLs

    Please use this subject line to ensure that it gets assigned to me.

    However, from what I see, one snapshot was imported from your live site to the test site.
    Live site:

    Test site:

    Let me know whether you were able to resolve this issue?

    Kind regards,
    Katya

  • Katya Tsihotska

    Hi Julius

    Thank you for providing credentials. I've looked at your site and was able to replicate the same issue.
    When the issue occurred, I've found the following error in browser console:

    Failed to load resource: the server responded with a status of 404 (Not Found) /wp-admin/admin-ajax.php

    You need to contact your host to find out if they are blocking/limiting requests to any files or especially the file 'yourdomain.com/wp-admin/admin-ajax.php', if they are then you should ask they whitelist this file for your domain as it is required to process Snapshots along with a lot of other requests from other plugins and even WordPress core and your theme.

    Here is a template message you can send to your host:

    Hello,
    
    I have a website running WordPress and it uses a backup plugin that makes requests to the file: 'http://mydomain.com/wp-admin/admin-ajax.php', the file exists but at some point, a request to this file returns a 404 (Not Found) error. 
    
    Request URL:http://your-domain.org/wp-admin/admin-ajax.php
    Request Method:POST
    Status Code:404 Not Found
    Remote Address:160.153.44.193:80
    Response Headers
    view source
    Cache-Control:no-cache, must-revalidate, max-age=0
    Connection:close
    Content-Encoding:gzip
    Content-Length:9067
    Content-Type:text/html; charset=UTF-8
    Date:Fri, 15 Sep 2017 22:09:38 GMT
    Expires:Wed, 11 Jan 1984 05:00:00 GMT
    Link:<http://mydomain.com/wp-json/>; rel="https://api.w.org/"
    Server:Apache/2.4.25
    Vary:Accept-Encoding,User-Agent
    X-Powered-By:PHP/7.1.7
    Request Headers
    view source
    
    I was wondering if you have firewall rules that limit the number of requests to this file. If yes, would you please raise the limit or allow the file to be requested without limit for my website.
    Thanks.

    Would you please contact your host and find out if they have such rules that limit access to files. Please let us know what they say so we can proceed with this.

    Kind regards,
    Katya

  • James Morris

    Hello Julius,

    I hope you don't mind if I jump in here, but I took a look at your site and found a few issues that were causing your backups to fail.

    First, your PHP configuration was using a very limited default which only allowed 128M of memory, which isn't really enough in most situations to run Snapshot. I've added a .user.ini file to your test site with the following directives:

    max_execution_time = 600
    memory_limit = 512M
    upload_max_filesize = 64M
    post_max_size = 64M

    I also updated your wp-config.php by adding the following define to enable WordPress to make use of the extra memory present:

    // Increase WP Memory Limit
    define('WP_MEMORY_LIMIT', '512M');

    This has given your site the resources needed to run Snapshot more reliably.

    I then checked your settings and found that you changed the directory where Snapshot stored files to NEWsnapshot. When doing this, the default directory no longer gets ignored when performing backups. This means the large zip files in that folder were getting included. Also, I found you had a wp-snapshots folder in the root of your site. These large files were also being backed up. I've reset the backup directory to snapshot and I've moved the large zip files out of the web root into your home directory for now.

    Once I did these cleanup procedures, I created a new Snapshot named WPMU DEV Test Snapshot and ran it. Everything worked perfectly. So, yes you should be able to backup your dev/test site and restore it to your production site now.

    Let us know if you have any further issues. We'll be more than happy to assist. :slight_smile:

    Best regards,

    James Morris