So

So ... my performance was at 70% ... i minification-ed the site ... and now my performance is down to 65% ... how?

  • Nastia

    Hello Amanda

    I trust you are doing well today!

    I've checked your site with Pingdom Tools, and the performance is at 69%. Have you activated Minification and Browser Cashing?

    Would you please grant access from WPMU DEV > Support so I can have a closer look at the plugin's settings?

    Please see the detailed instructions on the link below:
    https://premium.wpmudev.org/manuals/wpmu-dev-dashboard-enabling-staff-login/

    Let me know when you do!

    Cheers,
    Nastia

  • Nastia

    Hello Amanda

    Thank you for granting access to your site.

    Based from the Hummingbird reports, the Browser Cahing is not enabled. Would you please add this code to your .htaccess file:

    <IfModule mod_expires.c>
    ExpiresActive On
    ExpiresDefault A0
    
    <FilesMatch "\.(txt|xml|js)$">
    ExpiresDefault A691200
    </FilesMatch>
    
    <FilesMatch "\.(css)$">
    ExpiresDefault A691200
    </FilesMatch>
    
    <FilesMatch "\.(flv|ico|pdf|avi|mov|ppt|doc|mp3|wmv|wav|mp4|m4v|ogg|webm|aac)$">
    ExpiresDefault A691200
    </FilesMatch>
    
    <FilesMatch "\.(jpg|jpeg|png|gif|swf|webp)$">
    ExpiresDefault A691200
    </FilesMatch>
    </IfModule>
    
    <IfModule mod_headers.c>
      <FilesMatch "\.(txt|xml|js)$">
       Header set Cache-Control "max-age=691200"
      </FilesMatch>
    
      <FilesMatch "\.(css)$">
       Header set Cache-Control "max-age=691200"
      </FilesMatch>
    
      <FilesMatch "\.(flv|ico|pdf|avi|mov|ppt|doc|mp3|wmv|wav|mp4|m4v|ogg|webm|aac)$">
       Header set Cache-Control "max-age=691200"
      </FilesMatch>
    
      <FilesMatch "\.(jpg|jpeg|png|gif|swf|webp)$">
       Header set Cache-Control "max-age=691200"
      </FilesMatch>
    </IfModule>

    I see you do not have a cache plugin activated. We do recommend to use a cache plugin along with the Hummingbird, because the Hummingbird only handles browser cache and not site cache.

    In case W3 Total Cache that you have on your site is not what you are looking for, you can try the Super Cache plugin or the Batchcache . This should improve the server's response time.

    Once you do all this, clear your cache site, wait for about 20 to 30 minutes and then re-check your site performance again. (Google requires 20 to 30 min time to to show performance changes).

    We'll be waiting to hear the results. If you have issues with browser cache, please let me know!

    Cheers,
    Nastia

  • Amanda

    Thanks a bunch. I've got quite an extensive htaccess file ... do you think it'll conflict with anything?

    For instance .... iThemes Security stuff:

    # iThemes Security Config Details: 2
    	# Protect System Files - Security > Settings > System Tweaks > System Files
    	<files .htaccess>
    		<IfModule mod_authz_core.c>
    			Require all denied
    		</IfModule>
    		<IfModule !mod_authz_core.c>
    			Order allow,deny
    			Deny from all
    		</IfModule>
    	</files>
    	<files readme.html>
    		<IfModule mod_authz_core.c>
    			Require all denied
    		</IfModule>
    		<IfModule !mod_authz_core.c>
    			Order allow,deny
    			Deny from all
    		</IfModule>
    	</files>
    	<files readme.txt>
    		<IfModule mod_authz_core.c>
    			Require all denied
    		</IfModule>
    		<IfModule !mod_authz_core.c>
    			Order allow,deny
    			Deny from all
    		</IfModule>
    	</files>
    	<files install.php>
    		<IfModule mod_authz_core.c>
    			Require all denied
    		</IfModule>
    		<IfModule !mod_authz_core.c>
    			Order allow,deny
    			Deny from all
    		</IfModule>
    	</files>
    	<files wp-config.php>
    		<IfModule mod_authz_core.c>
    			Require all denied
    		</IfModule>
    		<IfModule !mod_authz_core.c>
    			Order allow,deny
    			Deny from all
    		</IfModule>
    	</files>

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.