Paypal Auto-return problem

Hi, so I've got Paypal Express Gateway activated (live mode). I set up the auto-return feature within Paypal. So after the user pays, he's returned to a specific page on my site (directcombatives.com/confirmation). But when he's returned, it brings up the Protected Content page. Yet, the page is not protected!

(The page is not listed under Membership Pages in Options).

How can this be resolved? Thanks.

  • Dharmendra

    Hello David,

    I hope you are well today and sorry to hear about the problem you are having.

    Could you please verify the settings by navigating to the WordPress dashboard ==> Membership ==> Settings ==> Membership pages (tab) ==> Registration completed page. Here you can select or create a page. When a user has signed up for membership and completed any payments required, they will be redirected to this page.

    If you still face the same issue, then could you please grant the support access via the WordPress Dashboard >> WPMU DEV Dashboard >> Support >> Staff Access >> Grant Access. So that I can take a closer look on it.

    I hope that helps. Please feel free to ask if you have more questions on the same.

    Take care!

  • Tyler Postle

    Hey David and rsbgm,

    Apologies for the slow reply on this one! I believe it is because the 50 page limit on the membership pages access level rule.

    Can you add this line to your wp-config.php

    define( 'MEMBERSHIP_PAGE_COUNT', 54);

    add it above the line: /* That's all, stop editing! Happy blogging. */

    That should make it to the Welcome page now. make sure it shows up in your pages rules now and ensure it is the correct setting to not be protected :slight_smile:

    Let me know if this does the trick for you.

    I would like to read your response on this issue. I am also experiencing this issue, only this time using PayPal Single Payment gateway. The auto-return works fine using PayPal Express Payment gateway.

    Hm. Odd that it works fine with one gateway and not the other. Does your page show in your pages menu for access rules?

    Cheers,
    Tyler

  • rsbgm

    Hi @Tyler Postle,

    Now that you mentioned it, the page seemed to be protected because I can't access it if not logged in. Checking on my admin, the page is not anywhere in the Negative rule for the access levels rules, nor, is it set as private and protected at page edit settings. The only item protected for my site are posts with a specific category.

    I have enabled Support Access. Please help to see how the page is Protected when I couldn't find anything that is protecting it?

    Thanks.

    _rsbgm

    ps: I have added the line of code you mentioned but have not tested it yet. Will provide feedback as soon as I am able to test it.

  • Tyler Postle

    Hey rsbgm,

    Thanks for your reply, how many pages do you have in your installation? Membership only displays 50 pages by default in the access levels. David has 54 which is why we used that code to up the limit to 54 (the page he needs listed is the last page). So, if your page is further down than 54 - you will have to up that number in your wp-config to whatever it is :slight_smile:

    Let us know how the testing goes!

    Cheers,
    Tyler

  • rsbgm

    Hi @Tyler,

    The Welcome page now works fine!

    The FIX:

    The initial Welcome page was done in the earlier free version of the Membership plugin as downloaded and installed from WP plugin center. It was reused by the new paid version given that I did not have the previous records deleted before the upgrade. I just had to delete the page and redo it.

    Auto redirection after payment processing is now ok.

    ps: The Welcome page is apparently Protected by default which makes sense because why whould a visitor need to see a Welcome page when it is solely for when a user just subscribes. Just saying...

    Thanks.

    _rsbgm

  • Tyler Postle

    Hey rsbgm,

    Glad it's working now! Thanks for posting the fix too; will likely help out other members in the future :slight_smile:

    The Welcome page is apparently Protected by default which makes sense because why whould a visitor need to see a Welcome page when it is solely for when a user just subscribes.

    Sometimes there can be a short delay before the membership level actually kicks in, this has caused issues in the past which can be resolved by not protecting the welcome page - gives a bit of a buffer in-between payment and the membership kicking in. You're right though, it being protected makes complete sense and you shouldn't have any issues with it that way but if you ever do then you know what to check.

    By the way, hope you've enjoyed your first 2 weeks at WPMU Dev so far! Welcome to the community.

    Cheers,
    Tyler

    PS. @David - keep us updated on your situation :slight_smile: We're here to help.

  • Tyler Postle

    Hey David,

    Hope your day is going well!

    How do I adjust the code accordingly?

    Change just the number. Example, if you have 60 pages then change the number from 54 to 60. That's it :slight_smile:

    (Also, since the Pages settings only lists 50 pages, how do I adjust the pages beyond 50 in the level settings?)

    With the above code added, it should expand the amount of pages in the access levels menu now. Instead of showing only 50, it will show whatever number you put in there. This way you can adjust all of the pages.

    Hope this helps! Let us know if you still need further assistance.

    Cheers,
    Tyler

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.