Social Marketing Ads Not Showing on Blog Index

What might keep the Social Marketing shortcode from rendering ads on the index/home page of a blog when they display fine on the Single post page? See links below for example...

Here the ad displays fine:
http://gifts.tripawds.com/2012/04/13/save-on-tripawds-mothers-day-jewelry-gifts/

But no ad shows in that same post here:
http://gifts.tripawds.com/

Am I missing a setting somewhere? I don't think it is theme related because it's also happening here...

See ad in this post:
http://agreda.com/blog/2012/04/03/how-to-increase-viral-product-sales/

See no ad in second post
http://agreda.com/blog/

Anyone else experiencing this behavior? I'm hoping the awesome support staff here can try to replicate this issue and help provide a fix. Thanks!

  • Arun Basil Lal
    • New Recruit

    Hello jcnjr,

    I tried it out and I see that too, its probably because the theme is using the_content() which to the best of my knowledge strips off short codes.

    I tried some stuff, but I couldn't fix it myself, let me ask Ve to help us out here. :slight_smile:

  • jcnjr
    • HummingBird

    Thanks for checking Arun! Interesting theory, but both themes used at the links I provided above use the_content() on both the index.php AND single.php template files. So that doesn't explain why the shortcodes work on one but not the other.

    I'm hoping a developer can chime in here soon. Especially since the agreda.com links above are for a rather favorable review about this plugin... which isn't working as expected.

  • jcnjr
    • HummingBird

    Hello? Sorry to be a pest, but does anybody have an update on this?

    I have now discovered that the MarketPress shortcode is also not rendering properly now that the post is on page/2 of the blog index. And, these shortcodes are also breaking the previous/next navigation links at the bottom of the page. (Don't ask me how it's breaking the navigation, but after the past four hours troubleshooting, I have just confirmed that both navigation links only appear if I remove both shortcodes from the post.)

    Check it out at http://agreda.com/blog/page/2/

    See the post titled "Learn how to earn an income Anywhere" and notice how it says "No Products" where the product image and buy button should be. Also notice how the social marketing ad is not next to the last picture in that post. For clarification, compare blog/page/2/ to the actual post page at http://agreda.com/blog/2012/02/24/learn-how-to-earn-an-income-anywhere/

    Also notice how there is no "Older Posts" link at bottom left compared to blog/page/3 which includes no MP or SM shortlinks.

    My Social marketing plugin review on the main blog page at http://agreda.com/blog/ is actually pretty embarrassing now considering the ad is not rendering as I describe... [sigh].

    Anyone? Thanks in advance for any help!

  • Vladislav
    • Dead Eye Dev

    Hi,

    The plugin currently renders ads on singular pages only (meaning, on pages where a single post is shown), which means that it won't render any ads on default home page or archive-type pages. The insertion routines are actually checking for this condition before doing anything else (i.e. adding javascript, stylesheets or markup). The plugin does come with a widget that can be rendered on any page, if that's a workable solution for your scenario.

  • jcnjr
    • HummingBird

    Thanks for the clarification VeBailovity. Guess we'll just need to keep that in mind when writing content around ads. Hopefully developers are looking into a way to render them on blog listings and archives.

    Now, does anyone have advice regarding how the unrendered ads are breaking navigation links? :disappointed:

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.