Social Marketing plugin not working correctly

When i click the button that opens the popup, im noticing a couple things.

1. When I hit the FB like button, the FB interface opens below the popup and you cant see the bottom of hit to complete a post. I can't move the interface, so the share can never be completed.

2. When i hit linkedIn share, it opens the linkedIn interface and allows me to share it no problem. But then it doesnt open up the coupon code section for the person to get their discount.

The plugin appears to be working perfectly for twitter and g+

    Vinod Dalvi

    Hi Michael,

    Welcome to the WPMU Dev community and thank you for your question.

    1. When I hit the FB like button, the FB interface opens below the popup and you cant see the bottom of hit to complete a post. I can't move the interface, so the share can never be completed.

    This happens when the content of Social Marketing pop up is large expanding the height of the pop up.

    To resolve the issue you can just reposition the facebook button and its comment pop up at the top of the Social Marketing pop up by adding the following CSS code in the style.css file of your child theme or add it in your site using the following plugin.

    http://wordpress.org/plugins/simple-custom-css

    #wdsm-popup_wrapper .wdsm_facebook_button .fb_iframe_widget .fb_iframe_widget_lift{
    top: -250px;
    position: absolute;
    }

    2. When i hit linkedIn share, it opens the linkedIn interface and allows me to share it no problem. But then it doesnt open up the coupon code section for the person to get their discount.

    I could reproduce this issue on my test site using latest version of Social Marketing plugn, it only displayed the page having the following text & links and doesn't display the coupon code.

    Next:
    Share link with others
    View link

    I have notified the plugin developer about this so that it can be fixed.

    The issue will be fixed ASAP.

    Would you mind if I logged in to your site and did some troubleshooting? This might help get to the bottom of this faster. If this is ok, just grant me temporary admin access to your site by clicking "Grant Access" button in the WPMU DEV Dashboard Settings as described on the following page and reply on this thread after granting it?

    https://premium.wpmudev.org/manuals/wpmu-dev-dashboard-enabling-staff-login/

    Thanks,
    Vinod Dalvi

    Ignacio

    Hi @Michael

    After debugging a lot, it seems that the problem is in LinkedIn. Though this thread in forums is old, there's still people asking about the problem in Nov 2014: https://developer.linkedin.com/thread/2805

    The problem is that when a suer successfully shares a thing in LinkedIn, Social Marketing passes a parameter ( a function name) to be executed after the share. This parameter is not working for LinkedIn so I guess I cannot do anything right now until it's fixed.

    Regards.
    Ignacio.