Social plugin not compatible with Woo Commerce

I am using a plugin called Social Agency that I purchased from JVZoo. When trying to install a shopping cart through Woo Commerce, I got a message telling me that it was not supported by Woo Commerce. Any suggestions?

  • Adam Czajczyk

    Hello Greg,

    I hope you're well today and thank you for your question!

    I think you're referring to the "WP Social Agency" theme, is that correct?

    I'm not able to test it as it's a premium theme to which I do not have access but indeed most of the themes do not include WooCommerce integration. This doesn't mean that they will not work. Even though WooCommerce reports that the theme is not compatible, you are still able to install it and give it a try. Many of such themes will work with WooCommerce flawlessly.

    In case it doesn't work well, first take a look here please:

    https://docs.woothemes.com/document/third-party-custom-theme-compatibility/

    There's also a handy video showing how some themes can be made WooCommerce-compatible:

    https://www.youtube.com/watch?v=MJN49MhZ1EA

    Having said that all, I'd strongly recommend getting in touch with WP Social Agency theme developer in a first place. Since its a premium theme and they should provide some sort of support. They should also be most qualified to update the theme in a way that would make it fully WooCommerce compatible.

    Kind regards,
    Adam

  • Greg

    Hey Adam,

    Yes, you are indeed correct that I am referring to the WP Social Agency theme. It's a sweet theme and I like it a lot. I hope I will NOT have to abandon it and go to another theme. I did indeed install a Woo Commerce shopping cart and got that 'support issue' message at the top of my plugin page. I have since deactivated that Woo Commerce shopping cart plugin. If I reinstall it and activate it is there an EASY way to test it to see if it indeed works and will accept payments for me? Please advise.

    I will indeed contact the developer/seller of that WP plugin first thing tomorrow morning to follow up like you recommended. Thank you, thank you for sharing the links to video resources that can help me and hopefully point me in the right direction for doing my own research. I really appreciate that. You have been EXTREMELY helpful with your advice. Thank you, thank you!

    All the best!

    Greg Potts

    On Sun, Jun 19, 2016 at 4:22 PM, WPMU DEV Community <contact@incsub.com> wrote:

    There is a new post on [Social plugin not compatible with Woo Commerce]

    Reply by: Adam Czajczyk

    Hello Greg,
    I hope you're well today and thank you for your question!
    I think you're referring to the "WP Social Agency" theme, is that correct?
    I'm not able to test it as it's a premium theme to which I do not have access but indeed most of the themes do not include WooCommerce integration. This doesn't mean that they will not work. Even though WooCommerce reports that the theme is not compatible, you are still able to install it and give it a try. Many of such themes will work with WooCommerce flawlessly.
    In case it doesn't work well, first take a look here please:
    https://docs.woothemes.com/document/third-party-custom-theme-compatibility/

    There's also a handy video showing how some themes can be made WooCommerce-compatible:
    https://www.youtube.com/watch?v=MJN49MhZ1EA

    Having said that all, I'd strongly recommend getting in touch with WP Social Agency theme developer in a first place. Since its a premium theme and they should provide some sort of support. They should also be most qualified to update the theme in a way that would make it fully WooCommerce compatible.
    Kind regards,
    Adam

    https://premium.wpmudev.org/forums/topic/social-plugin-not-compatible-with-woo-commerce#post-1099659

    Please do not reply to this notification via e-mail. All replies should be made on the forum thread.
    ==============================================================
    Unsubscribe - Stop receiving notifications from this thread:
    https://premium.wpmudev.org/forums/topic/social-plugin-not-compatible-with-woo-commerce?unsubscribe=176731#post-1099659
    ==============================================================

  • Predrag Dubajic

    Hi Greg,

    You can enter PayPal sandbox details, or any other gateway sandbox, and test the payment process, I don't think there's an easier way to be sure what will happen.

    As Adam mentioned above this notification can simply meant that theme doesn't officially support Woocommerce but it still can work on it without any issues if the theme follows WP developer rules.

    Best regards,
    Predrag

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.