Solution: Domain Mapping Health Status Invalid

Hello Good people,

I found a solution to the famous Domain Mapping Health Status Invalid issue. This may not work for everyone but it worked for me.

I stumbled upon this by trial and error testing after reading *many* support threads here where users did not have their IP or hosting setup correctly, and where WPMUDEV support got admin access to sites and went in and made manual changes to databases, to the plugins, etc. and then let us know that the latest release of Domain Mapping plugin would have the fix.

Well, as of today I was getting Invalid status on seven of my nine subsites using the most current version of the plugin. So I went to work on things I could do.

Before going into the solution you *MUST* have your multisite set up correctly–or you’ll just be wasting your time.

1. Your multisite install must have a DEDICATED IP pointed DIRECTLY to the install; not to an account, not to a shared hosting folder with all your domains. The dedicated IP address must point to the root domain name of your multisite install.

2. All of your subdomains must have either an A record or a CName record using that dedicated IP address. I use A records–and with my DNS pointed to Site5 hosting managing the A records is easy, easy, easy.

3. You must have completed all of the other required setups for a multisite and for domain mapping. This one should actually be at the top of the page. If you “think” you’ve done everything, but you didn’t follow a checklist, and you “maybe” got everything right in the setups, stop here and go do it all perfectly step by step first.

If you’ve got everything set up correctly and you’re still getting the Health Status = Invalid message here’s what worked for me.

1. Go into Network Admin > Settings > Domain Mapping > Mapping options tab.

2. Make sure the Server IP Address field has the correct IP address.

3. Lower on the same page, look for Verify domain’s DNS settings. Set that to No. Save the settings on the page.

4. Go to each subsite’s own dashboard… Tools > Domain Mapping. If you have this issue you’ll see that the Health Status is invalid there as well.

5. Delete the mapped domain.

6. Re-add the domain name AND set the drop down “Front end redirect should be” to “disabled and entered domain should be used” and click the Map Domain button.

In my case the Health Status turned to valid the moment the save refreshed.

I repeated this with all of the remaining invalid mapped domains and now they’re all valid.

I hope this helped a few people.

If this helped you please don’t be shy with the whole point throwing at me thing :slight_smile: