Some help making Custompress work with my theme

Hello,

I've been trying for a few weeks and I'm really struggling with getting my custompress post types to display effectively in my theme: Unyson Woffice

For my custom post types, I'm trying to make them display in the exact same manner as a "post" is displayed. The only step that is still lacking is that the custom fields (created by the plugin "advanced custom fields") within my custom post types are not displaying in the front-end.

This becomes complicated as my theme also incorporates a front-end editor for users, displaying fields as editable for users with permission. Not only are my custom fields not displaying, they are not present in the front-end editor either. In both places, the only thing present is the unused "post content" which is not used in my custom post types.

"Minutes" Post Type
This post type is arranged to be exactly like posts, but instead of the standard post content, it is replaced by 5 custom fields from "Advanced Custom Fields" plugin - call to order, old business, new business, announcements, and adjournment. The "minutes" post type, and all of these fields, is supposed to be arranged and displayed in exactly the same way as a standard post. The only exception is that the post content is replaced by those 5 custom fields. That's it.

Is this something you might be able to help with? I thought it might be convienient for me to use custompress so that I may slightly customize a few categories of content, and this has turned into a massive project.

Thanks

  • Rupok

    Hi Christopher, hope you had a wonderful day.

    it is replaced by 5 custom fields from "Advanced Custom Fields" plugin

    Could you try using the Custom Fields creation option inside CursomPress?

    I could tell you better about the issue if I could see it live, check your current configuration and make some tests on your site. I tried to login with Support Access, but it's showing me "0". Can you please revoke and grant us permission again so we can have a better look and try to resolve this for your as soon as possible?

    Have a nice day. Cheers!
    Rupok

  • Kasia Swiderska

    Hello Christopher,

    For my custom post types, I'm trying to make them display in the exact same manner as a "post" is displayed. The only step that is still lacking is that the custom fields (created by the plugin "advanced custom fields") within my custom post types are not displaying in the front-end.

    Did you add those fields to custom post template? No custom fields (it doesn't matter if they are added by function in functions.php or ACF or CustomPress) will show on front end if the template for this post is not prepared to display them.

    To add those fields to template you need to copy file single.php to single-minute.php - in single-minute.php file you will need then add functions that will display values of the custom fields - click in each custom field in embed code and you will get those functions

    <?php echo do_shortcode('[ct id="_ct_text_579936513ab8a" property="value"]'); ?>

    This becomes complicated as my theme also incorporates a front-end editor for users, displaying fields as editable for users with permission. Not only are my custom fields not displaying, they are not present in the front-end editor either.

    It is probably because this front end editor does not have full support for custom fields and custom post types and uses some custom function. Because it is paid theme you have support from its author and you can ask what needs to be modified so it will start to supporting custom fields.

    kind regards,
    Kasia

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.