Some images are broken after migration

I moved the development site to the actual live domain. Everything works except there are some images missing in Upfront, but the images are on the server
I've used Search&Replace to replace all mentions of the dev domain with the live domain, but it doesn't help. Even thogh all link are correct now, they still return 404 error.

  • Katya Tsihotska

    HI Claudio

    Hope you're having a wonderful day!

    I've checked your site again and I've noticed that images with the issue return nginx 404 error instead of the WordPress "Page not found". From what I suppose that this could be some server configuration issue. Could you please try to contact your hosting provider with regards to this issue. Let us know if they'll provide you with any valuable information.

    Also, I'm going to need to ping our SLS team (code experts) and get their help on this. Since this is a bit more of an advanced query, it may take a little bit longer to get a reply back about this, but one of us will post back with feedback as soon as possible.

    Kind regards,
    Katya

  • Katya Tsihotska

    Hi Claudio

    Hope you're fine today!

    I've checked your site and it looks like all images are working fine now. Were you manage to fix the issue? If so, would you mind to share the solution with us? I think other members will find that helpful in the similar situation.

    If the issue still persists for you, could you describe step by step how we can see or replicate it?
    Could you also describe step by step how can I replicate the issue with uploading videos?

    Kind regards,
    Katya

  • Katya Tsihotska

    Hi Claudio

    I've had a closer look at your site and I noticed that media uploading doesn't work on your site at all, even via the native WordPress Media Upload option (WP Admin -> Media -> Add new). Also, media files aren't visible in grid mode in the media library, they are visible only in list mode.

    It looks like the installation was corrupted during the migration. I've also checked debug.log but wasn't able to find any clue to the issue. Let me know which plugin or tool did you use to migrate the site. Also, let me know does everything work fine on the original site or you have the same issues there?

    To further investigate the issue we need to have some additional credentials. Could you send us your details through our contact form using the following template:

    Subject: "Attn: Katya Tsihotska"
    -WordPress admin username
    -WordPress admin password
    -WordPress login URL

    -cPanel username
    -cPanel password
    -cPanel login URL
    -any other relevant URLs

    Please use this subject line to ensure that it gets assigned to me. DO NOT post any credentials here, as it's a public forum.

    Kind regards,
    Katya

  • Claudio

    Ok, there are more issues. I can not make any new user. Also when I look into the "wpmudev support system info" I can see max_execution_time = 0. But on the server it is 60.

    Server settings:
    memory_limit = 128M (Standard)
    max_execution_time = 60
    max_input_time = 60 (Standard)
    post_max_size = 42M
    upload_max_filesize = 42M
    opcache.enable = on (Standard)

    I have send you the ftp credentials.

  • Katya Tsihotska

    Hi Claudio

    Hope you had a great day!

    Ok, there are more issues. I can not make any new user.

    It looks like the database was corrupted, as corrupted database usually cause issues that you're having at the moment. That's why I asked for cPanel credentials, FTP credentials a bit not suitable in such case, as we cannot check the database via FTP. Let me know if you can provide us with access to the cPanel or directly to the PHPMyAdmin. If so, could you send us your details through our contact form using the following template:

    Subject: "Attn: Katya Tsihotska"
    -cPanel or PHPMyAdmin username
    -cPanel or PHPMyAdmin password
    -cPanel or PHPMyAdmin login URL
    -any other relevant URLs
    -link back to this thread for reference

    Please use this subject line to ensure that it gets assigned to me.

    Also, in order to fix the possible issue with the database, could you try to follow the instructions here:
    https://www.maketecheasier.com/fix-corrupted-wordpress-database-2/
    Let me know about results.

    Also when I look into the "wpmudev support system info" I can see max_execution_time = 0. But on the server it is 60.

    Server settings:
    memory_limit = 128M (Standard)
    max_execution_time = 60
    max_input_time = 60 (Standard)
    post_max_size = 42M
    upload_max_filesize = 42M
    opcache.enable = on (Standard)

    Thing is that your server settings can be overwritten locally by using php.ini, .htaccess or wp-config.php files. I've found php.ini file in the root folder of your site and also found the following code in wp-config.php:
    define('WP_MEMORY_LIMIT', '3000M');
    So, it's the cause why you see different values in server setting and at the System Info section of the WPMU DEV Dashboard.

    Kind regards,
    Katya

  • Katya Tsihotska

    Hi Claudio

    Hope you had a great day!

    Here is the instruction on how to provide the direct access to the phpMyAdmin in Plesk:
    https://docs.plesk.com/en-US/12.5/administrator-guide/database-servers/database-management-tools.72893/

    Also. let me know if you have the same issues on the source site? If no, I suppose that it would be better trying to re-migrate it again. I mean start the whole migration process from scratch with creating new database dump and files archive, as this could be much easier than fixing the corrupted database. Here are few articles about how to do this in different ways:
    https://premium.wpmudev.org/blog/easy-migration-snapshot/
    https://premium.wpmudev.org/blog/migrate-wordpress-wp-migrate-db-plugin/

    Also, you can try to use one of the following plugins:
    https://wordpress.org/plugins/all-in-one-wp-migration/
    https://wordpress.org/plugins/duplicator/

    Kind regards,
    Katya

  • Lindeni Mahlalela

    Hello Claudio

    I hope you are doing great today. I am sorry that you are having issues on your website and I hope to help in any way possible.

    I tried to access your website in order to try and find out what the issue is but unfortunately the Support Access has expired or was revoked and the FTP login provided does not work as it gives the following error:

    Command:	USER wpmudev
    Response:	331 Password required for wpmudev
    Command:	PASS ********
    Response:	530 Login incorrect.
    Error:	Critical error: Could not connect to server

    If you still need help with this please enable support access and provide updated and working FTP login details. Issues like this take time to get resolved and support access usually expire before we can find a solution so I suggest that you share WordPress admin login so that we can work on this without limitations. You can also create a temporal admin account if you are not comfortable sharing the main one. You can share the login details via our secure contact form, on the contact page choose "I have a different question" then in the subject line write "Att: Lindeni Mahlalela" then in the Message box include:

    - WordPress admin login (login url, username and password)
    - FTP login details (ftp host, port, username and password)
    - Link back to this thread for reference.

    Once we have that we will continue investigating the issue. Please let us know if you have any concerns or questions.

    Have a nice day.
    Mahlamusa

  • Lindeni Mahlalela

    Hello Claudio

    I hope you are doing great today. Thank you for sending in the login information. I was able to login to your control panel to have a look at your setup.

    I inspected both your file system and the database and everything seems to be ok there. I verified that when uploading a new media file it gets saved in the uploads folder and also a new corresponding entry is created in the database. But if I go to the Media library in WordPress admin, it says "No media files found." but they actually exist in files and database entries.

    This made me think that there is something else causing probably a PHP error or something then I checked the debug file located in wp-content/debug.log and found a few PHP warnings that may result in the media not showing, these warnings look like this:

    [17-Feb-2018 20:50:50 UTC] PHP Notice: Trying to get property of non-object in /<DOMAIN_HTDOCS_DIRECTORY>/wp-includes/post.php on line 5878

    This is just a warning but I think its worth investigating as to why it occurs because media files are stored as posts in the database but with a different post type. Its possible that the media files could not be found because the PHP got a different data format while it expected an object.

    I have also noticed that your total disk usage for the account is currently at 111% of your total allocated space, this could cause your website to fail to render properly because of limited disk space. When a server is rendering a page it requires some free space to temporarily store the content before returning it to the browser. So I suggest you free up some space and do the testing. I noticed that most of the space is consumed by the dev.yourdomain.de which seems to have a couple of backups and duplicate folders. Please try to free up some space so that the total used is less than 100% this will give your website some room to work in.

    Please do this first and test, we will see if that solves the problem. I ask this because I have checked your website properly and it seems everything is fine except the Disk usage is exceeded. I even tried to change PHP Version and it did not work, also a plugin conflict did not work.

    Please let us know how it goes after freeing up some space, also let us know if you need any further assistance with regards to this and we will always happy to help in anyway possible.

    Have a nice day.
    Mahlamusa

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.