Some images doesnt show

Hi,
I have turn and activate my https but looks some images doesnt show, I have checked the images and they have https but still not work.
Can I have some help?
I have looked and I have found some post with the same problem, and I have tried the solutions they show but still have the same problem.

The links where I have the problems are:
ferreirex.com - ricardoferreira.thestrongo.com
portasegura.com - portasegura.thestrongo.com

and some websites inside the networks shows as a non-secure on Google Chrome like ferreirex.thestrongo.com.

  • Soumendra Mishra

    Hello ferreirex,

    Thank you for contacting us today and sorry for the issue you are facing.

    I have checked both the URLs (ferreirex.com and portasegura.com) where you have mentioned that you cannot see some of your images. But I cannot replicate the issue there. Can you please share the screenshot(s) where you are having trouble seeing the images so that it would be easy for me to replicate the issue and help you further.

    Also, can you please confirm that whether you have wildcard SSL certificate configured because that is needed for the subsites to have a secure connection?

    Also, if possible could you please grant support access so we can have a closer look at this? You can follow this link to grant support access through your dashboard directly:
    https://premium.wpmudev.org/docs/getting-started/getting-support/#chapter-4

    Regarding the non-secure warning in ferreirex.thestrongo.com, this is due to the mixed content as some of the links on the website are still "http://".

    For overcoming the mixed content error you can either change all the "http://" links to "https://" manually or you can use any Third party plugin which can help you for that like:
    https://wordpress.org/plugins/wp-force-ssl/
    https://wordpress.org/plugins/really-simple-ssl/

    Cheers,
    Soumendra

  • Soumendra Mishra

    Hello,

    Thank you for your reply.

    Upon further checking, it seems that your SSL certificate is already expired and that is most likely the reason why the images are not showing there in the site. You need to fix the SSL certificate issue first and after that, the images should show again.

    I've gone through the https://ferreirex.thestrongo.com/ also and found that you have added the URL manually in a couple of places which are causing the mixed content issue.
    I have fixed some of them like logo URL and the footer menu URLs. But there is still two "http://" extensions in your favicon and in one of the JS that you have added manually. You need to replace the "http://" with "https://" to overcome the mixed content issue.

    You can also check the mixed content errors by inspecting the site with browser developer tool ("Ctrl+Option+j" for chrome and "Ctrl+Option+k" for Firefox). Inspecting the site will help you to get the errors and you need to find and replace the links manually with "https://".

    Cheers,
    Soumendra

  • ferreirex

    Hi Soumendra Mishra

    I have checked the SSL certificate and just ends on 25 of November.

    I have found why in some placed doesn't work the changes I have been doing, is in admin area show pagename.thestrongo.com/images and to works properly fine need to be pagename.com/images

    How have you force for the all pages (admin area) go to the domain and not a sub-domain on WP MU?

    Another problem is on my computer everything looks work fine, but if I go to my mobile or tablet doesn't work, I have double refreshed, use the Shift+Cmd+R and still show everything...

    Question:
    If I get other a new page inside WP MU installation and after a few days add the domain, so I going to have the same problem?

  • Soumendra Mishra

    Hello ferreirex,

    Hope you are doing well today.

    Can you please provide additional information about what you are referring? I’m having trouble understanding the below points:

    How have you force for the all pages (admin area) go to the domain and not a sub-domain on WP MU?

    &

    Question:
    If I get other a new page inside WP MU installation and after a few days add the domain, so I going to have the same problem?

    Regarding the images which are showing on the computer and not on other devices, the URL of the images are correct but in Safari browser it is showing expired SSL certificate which is blocking the images.
    But when you see the same images on the computer it shows "Not secure" option in browser address bar but it does load them.

    Can you please let me know which browsers you are using for that.

    Please get in touch with your hosting provider so they can look into the SSL certificate issue for you.

    Thank you.

  • Soumendra Mishra

    Hello ferreirex,

    Thank you for contacting us today.

    I'm not quite sure what do you mean by:

    The question I have ask , maybe is better ask if have any troubles when do I need to do the domain mapping.

    But if your main SSL certificate is issued by a trusted authority, it is valid and up to date then the site will be fine. Also, you need to make sure that all your images in the site are referring to "https://" without "http://"

    If you are using domain mapping then you need an additional single domain certificate to be installed for each of the mapped domains to make it work properly and avoid mixed content and cross-domain reference issues.

    Hope that helps.

    Thank you.

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.