Some pages randomly lose association with their parent pages

Hello. I am using Membership version 3.5.1.2.

I am having an bizarre issue. Sometimes when clicking around my site as a stranger (Visitor role), I will visit a page and I will get an error saying it doesn't exist. These pages I run into trouble with have a Parent page associated with it. The reason why I receive the error when trying to go to the page because the page somehow lost it’s association to its parent page, thus the link no longer works because the link contains the URL with the parent page in it. All of a sudden, a bunch of my pages completely lost the Parent page I assigned them to.

For my site, for example, I had the "My Membership Benefits" page set to the Parent page of "Premaccess3" and the "Membership Subscription" page set to the Parent page of "Premaccess1". As I was clicking around the site and tried to go to their of these pages, I received an error because they no longer were associated to the parent page I assigned to them.

When you view the Page summary view in my Dashboard, you will see "Premaccess3" and "Premaccess1" as a Parent to a bunch of pages below them, but you see the "My Membership Benefits" page and the "Membership Subscription" page by themselves, not under their previous Parent pages. And what's even more bizarre is if you edit those 2 pages and try to reassign "Premaccess3" and "Premaccess1" as their Parent, there is no longer an option for "Premaccess3" and "Premaccess1" in the Parent drop down. And all those other pages I assigned to “Premaccess3” and “Premaccess1” (that still appear to be assigned to them on the Page summary view) are not indented in the Parent drop down, thus not able to be chosen as the parent.

Basically, some of my pages are losing the parent page I assigned to them RANDOMLY without me doing anything but click around the site.

And this usually happens for a few hours. Then I will see the “Premaccess3” and “Premaccess1” back in the drop down so I can assigned them to pages. Usually at this point I edit the “My Membership Benefits” page and the “My Subscription” page and re-assign those parent pages to them. But during the time they became unassigned, my site is virtually unusable to visitors.

Have you ever heard of anything like this?

I just granted you access to look around if you need to.

Thank you.

  • PC

    Hello there Nick,

    Thanks for posting on the forums.

    I have not heard of anything like this before however we will try to find out what is going on.

    First of all take a backup of the site and then check for any database errors if you see any. Check the server error logs as well to see if there is something related.

    Since when have you been facing the issue ? Also, do you go to Pages >> All Pages when that happens and see what is going on there and you see the child pages or not ?

    Also, when you said its happening as a visitor, did you try logging in as an admin and tested if it worked fine ?

    Please advise.

    Cheers, PC

  • Nick

    Hi @PC,

    Thank you for your response. I just took a backup. When you say "check for any database errors", I am not sure what you mean and how I check?

    There were no errors in the PHP error log. There are errors in the Apache server logs.

    I have run into this many many times. Usually it comes right around the time that user_id=0 bug that @Jonathan tried to fix a bunch of times. I don't know if this last time I encountered the issue is related to the user_id=0 bug or not because it was supposedly fixed in the latest release of Membership 3.5.1.2. It may be completely unrelated.

    When the issue occurs, it strips away the Parent page I assigned to the page, thus the URL is incorrect on the front end because it contains the Parent page that got stripped away. When I go to Pages > All Pages, the two pages that were affected were NOT represented as Child pages of the "Premaccess3" and "Premaccess1". However there were still a bunch of other pages as Child pages. And when I edited one of those 2 affected pages and clicked the Parent page drop down, the "Premaccess3" and "Premaccess1" were NOT listed, and all the Child pages shown on Pages > All Pages were not indented in the drop down like they should be.

    Once this issue occurs, all the roles encounter it, including the Admin role.

    The last time I encountered the issue was between April 15th and April 16th. May I send you the Apache Error Log files from April 15th and April 16th? It's not too large for those days. When I look in those logs I just don't know what to look for. May I please send it to you via your secure contact us form?

    Thank you kindly.

  • Nick

    Hi @PC,

    I should add another detail. After 6 hours, the "Premaccess1" and "Premaccess3" pages came back to the Parent page drop down menu (when editing a page.) They seemed to just randomly come back after XX hours. So once I saw they were back, I edited the two affected pages and re-assigned them to the appropriate Parent page and everything was fine.

    I don't really want to have to do that though!

    Thank you.

  • Nick

    Hi @PC, @Jonathan, and @Fabio Jun

    I have found the cause of the issue. This issue has to do with the "View Site As" functionality for the Membership plugin.

    Here are the steps I took to recreate the issue.

    #1) I set my "View Site As" to one of my roles called "Player - Full" and clicked around my site to test some things.

    #2) I then went back to the Dashboard and chose to edit a page called "College Pathway" (which had been set to the "premaccess2" Parent page.)

    #3) I made a few text changes and clicked Publish.

    #4) The "College Pathway" page, which had the URL of "mydomain.com/premaccess2/college-pathway" had the "premaccess2" dropped and the URL became "mydomain.com/college-pathway".

    #5) When I went back to edit the page and reassign the "premaccess2" Parent page, I clicked in the Parent drop down menu and the "premaccess 1", "premaccess 2", and "premaccess 3" pages DISAPPEARED from the drop down!

    #6) Then I hovered over "View Site As" and clicked Reset, and it became "Membership Admin".

    #7) When I looked in the Parent drop down menu again while in edit page mode, the 3 premaccess pages CAME BACK!

    #8) I then chose the "premaccess2" as the parent and clicked publish (while my role was View Site As: Membership Admin"), and the URL went back to mydomain.com/premaccess2/college-pathway. So everything was fine!

    So it looks like weird issues happen when doing things in the Dashboard after choosing the "View Site As" as something other than Membership Admin. When my "View Site As" was set to "Player - Full" and I tried to edit pages, these weird issues occurred.

    What are all of your thoughts on this?

    If this is the way its supposed to work, then I will just make a mental note never to do anything in the dashboard when my "View Site As" is set to anything other than Membership Admin. But if its a bug, just wanted to pass along!

    Thanks,
    Nick

  • Nick

    Hi @Fabio,
    Thank you for your reply. I completely agree with you about using the View Site As functionality to edit pages.

    I just wanted to point this out to others who may encounter this issue. When using the View Site As to test a member's experience with a specific subscription, its easy to forget you are locked in as that view until changing it or clicking Reset, and if you forget to click Reset and go back to the Dashboard to make edits to pages, these issues will occur.

    Just figured I would try to help other members by outlining my steps to cause the issue :slight_smile:

    Thanks again for your excellent support and care for the WPMU member community!

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.