Some reason, WHMCS Integration "Encode URL" isn't "encoding" and shows same

It appears that for some reason, the WHMCS Integration plugin that I have installed on my site isn't actually modifying the URL to show properly for the site. I am currently running the latest v1.3 available. I enter the URL of the WHMCS install, press the "Encode the URL" button and the page executes, reloads and shows the same identical link as I entered in the previous box. No errors, nothing? No changes have been made (that I'm aware of). I use no caching plugins. WHMCS settings have not been modified and the plugin works throughout the site like it always has. Oddly enough, this is now happening. I did actually make a change, that being the only change I made was to upgrade and install the WHMCS 6.1x version, set the WHMCS integration plugin to "Auto Detect" and let it be.

  • Vinod Dalvi
    • WP Unicorn

    Hi Matt,

    I hope you are well today and thanks for posting on the forum.

    Would you mind if I logged in to your site and did some troubleshooting? This might help get to the bottom of this faster. If this is ok, just grant me temporary admin access to your site by clicking "Grant Access" button in the WPMU DEV Dashboard Settings as described on the following page and reply on this thread after granting it?

    https://premium.wpmudev.org/manuals/wpmu-dev-dashboard-enabling-staff-login/

    Kind Regards,
    Vinod Dalvi

  • Matt
    • Design Lord, Child of Thor

    Yes, I have and as I figured, got the same result. It makes no difference what URL is entered, the same thing happens where the one entered is equivalent to the one that shows as "encoded". As I mentioned I would check status this morning after Vinod's investigation for results as I am in NY time zone. It's morning now and I'm back in the office if needed.

  • Kasia Swiderska
    • Support nomad

    Hello Matt,

    I'm sorry for the extreme delay - I've checked this issue on our WHMCS installation and url encoder is working correctly. However our WHMCS version is lower that you have - so this could be reason of this not working. I flagged plugin developer to have his opinion on this matter.

    Kind regards,
    Kasia

  • Jose
    • Bruno Diaz

    Hey there Matt,

    Hope you are doing great.

    This is definitively a weird issue. At first glance, I would supect either of mbstring extension not installed in your server or the remote host parameter not set correctly.
    The odd thing is that any of these issues would prevent your Integration to work.

    If you are still experiencing the problem, I'll need to log into your site and run some test directly in your server.
    In order to do so, please send me the following information via contact form :

    - In the subject field add "Attn: Jose”
    - Link back to this thread
    - Include WP admin/network credentials and login url.
    - Include WP WHMCS admin credentials and login url.
    - Include FTP host and credentials for both installs.

    On the contact form, select "I have a different question", this ensures it comes through and gets assigned to me.

    Thanks in advance,
    José

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.