Something missing from "This entry was posted in ."

"This entry was posted in ." What's supposed to be there before the full stop, and why isn't it there?

  • Patrick
    • Support Monkey

    Hi there @Outi

    I hope you're having a great day!

    That type of text usually appears in the post meta at the top and/or bottom of a WordPress post. What appears before the full-stop is either the category(ies) and/or tag(s) that post is filed under.

    So if the post has no assigned categories or tags, that will likely appear empty.

  • Outi
    • Flash Drive

    Ok, thanks for your reply. This happens on the automatically generated course description page, so it doesn't really have a post category or tags. Does it make sense having the line there at all?

    I tried assigning a category to the course, to see if the line would fill with the category. But the category won't stick. I save, and after some time the category has reset in the settings back to none.

  • Ash
    • WordPress Hacker

    Hello @Outi

    I tried assigning a category to the course, to see if the line would fill with the category. But the category won't stick. I save, and after some time the category has reset in the settings back to none.

    Is there any pattern that after how long the category has been reset?

    Also, would you please enable support access so that I can take a look?

    Cheers
    Ash

  • Outi
    • Flash Drive

    How do I give you support access? Create a new user, assign it instructor rights and mail you the login info?

    The resetting happened multiple times during one evening. So at max maybe an hour. But once at least I checked pretty soon after setting it, and it was still there. Not sure how much time "pretty soon" was... Maybe 10min?

  • Sumit Kumar
    • Site Builder, Child of Zeus

    Hi @Outi,

    Thanks for illustrating your issue with "category-resetting". This is some in-different behavior, I must say. Well, we need to go deep in your site dashboard to see whats causing that issue. Can you enable support access for that?

    You can do this by going to our WPMU Dashboard Menu => Support => Support Access => Grant Access. Easy instructions are in this link: https://premium.wpmudev.org/manuals/wpmu-dev-dashboard-enabling-staff-login/

    Will be looking forward to resolve your issue.
    Have a great day :slight_smile:

    Warm Regards,
    Sumit

  • Ash
    • WordPress Hacker

    Hello @Outi

    I have just tested a lot in your site and in my test site. There are some issues in that entry meta though. But once you select a course category, it worked fine for me.

    I can see you are using a translated language file. Would you please quickly turn off WPLANG from wp-config.php and check if you can see category by then?

    The issue I found that if I don't have more than one post category the entry meta doesn't show. I am tagging the developer @Marko Miljus for his valuable opinion on this.

    Meantime, please let me know after disabling WPLANG.

    Cheers
    Ash

  • Outi
    • Flash Drive

    Hi @Ashok. I changed the language from WP General Settings, I suppose that's as good as changing the php file but just more user friendly. Do tell me if I really need to change the php file.

    This change into English didn't change the behaviour. The disappearing of category is still there, both from course settings and the course info page. However, I think I now found out what makes the category disappear from the course settings. It's when you go to settings step 6, and press "Done". The next time you go see the category settings, it's reset.

  • Andre Foisy
    • The Incredible Code Injector

    Hello there @Outi,

    I hope you are going well.

    I've been making some more tests from your site and dashboard, and from my own test site as well and I've been able to reproduce what you describe as well, and I can confirm this is a bug and will immediately flag the developer as a confirmed bug so he can fix that as soon as possible.

    Thanks for your help and patience in this matter. :slight_smile:

    Regards,
    Andre

  • Outi
    • Flash Drive

    The category resetting part of the problem was fixed with the update, thanks for that.

    But the category still can't be seen in the string "This entry was posted in ." I'm using the CoursePress theme, if that has any effect on this issue.

    Frankly, I don't really care that it's missing, in my opinion the whole text is meaningless on the course description page, as it's not really a blog post.

  • Ash
    • WordPress Hacker

    Hello @Outi

    I have just tested with latest update and it worked fine for me in coursepress theme.

    If you want to hide the text you can try the simple css:

    .course footer.entry-meta{
    display: none !important;
    }

    You can add this to a theme's stylesheet, in a child theme, or using a plugin like My Custom CSS.

    Hope it helps :slight_smile: Please feel free to ask more question if you have.

    Cheers
    Ash

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.