Spirit menu initiates with wrong menu links.

When you activate the spirit theme it create a menu "Main Menu".

This menu contains the following links:

/get-quote-inner/
/services-inner/
/blog-post-8/
/service-fence-inner/
/product/this-is-a-product/
/expert/gagan-goraya/

However, it adds these pages:

/about/
/blog/
/contactus/
/gallery/
/login/
/services/
/sing-page-2-php/
/testimonials/

This means that as soon as anyone activates the theme they get a bunch of pages added they don't know about which is confusing and the menu all results in 404 errors so the first impression is that the theme is broken.

Any chance to get it fixed?

  • Adam Czajczyk
    • Support Gorilla

    Hey Mike!

    This pages are there because a lot of our members setup and activate Upfront-based themes right on their "fresh and clean" WP installs. Also, setup on "empty" site Upfront-based theme may just seem "broken" at first glance. Therefore it's a feature rather than a bug.

    However, I think giving an option to decide whether these pages/menus should be installed or not could make a great feature. That said, I'm moving this thread to our "Features and Feedback" forum and hopefully more members of our community will support the idea.

    Thanks for pointing this out!

    Cheers,
    Adam

    • Mike
      • The Bug Hunter

      Hi @Adam Czajczyk

      Thanks for the reply.

      I think you have misunderstood me. This is definitely not a feature request.

      Humor me if you will and activate spirit on an empty website. Then try and click on a link in the menu. You will see the links do not point to the pages that have been generated.

      At some point the sample pages have been changed but the menu has been overlooked by the devs. It's just a case of updating the menu links to link to correct pages that you have generated.

      For further proof please compare your newly installed spirit theme with your own live demo at: http://demo.upfront.pro/spirit/

      You will see the menu in your demo correctly links through to the demo pages, however the newly installed one will not. I listed the pages still being linked to in my original post.

      There is a change here that needs to be merged to release branch.

      Please re-consider this as broken links being generated is a bug and not a feature and give a bad impression.

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.