SQL out of memory error with Hummingbird

After I install Hummingbird error appears when I navigate to the Hummingbird -> Dashboard
Warning: mysqli_query(): (HY000/2008): MySQL client ran out of memory in /home/****/public_html/wp-includes/wp-db.php on line 1924

  • Matt

    I have been talking to my host (siteground, dedicated server) and they keep avoiding the question about mysql memory when I ask them could they increase it. I'm going to ask again shortly and ask them to stop skirting around the subject. They keep referring me to you guys about the warning despite the fact I believe it has something to do with the server setup. I did have the same issue with one other site and hummingbird a couple of weeks ago, but the site was pretty well optimized already so I just deactivated hummingbird and forgot about it. It's definitely not a plugin or theme conflict as I cloned the site on the server and deactivated all plugins and changed to the wordpress default theme and the error still persists on the hummingbird dashboard, and on the front end if hummingbird is activated. Might be worth mentioning that this so far seems to be just a warning and not a fatal error. I believe I used to have w3 total cache installed on this site and I know that it can sometimes leave behind files which then conflict with other caching plugins. Perhaps this could be something to do with it?

  • Matt

    So siteground finally upped the SQL memory limit to 64MB from the previous setting of 16MB which has had no effect. I have also replaced the .htaccess with a clean one and no effect.
    It seems to be something to do with the minification part of hummingbird and I managed to squeeze some more details out of the error, perhaps these might help diagnose it better?

    Warning: mysqli_query(): (HY000/2008): MySQL client ran out of memory in /home/mcs/staging/2/wp-includes/wp-db.php on line 1924

    WordPress database error: [MySQL client ran out of memory]
    SELECT ey8a_posts.* FROM ey8a_posts WHERE 1=1 AND ey8a_posts.post_type = 'wphb_minify_group' AND ((ey8a_posts.post_status = 'publish')) ORDER BY ey8a_posts.post_date DESC

    WordPress database error: [Lost connection to MySQL server during query]
    SELECT option_value FROM ey8a_options WHERE option_name = '_transient_timeout_wphb-minification-files-scanning' LIMIT 1

  • Dimitris

    Hello Matt,

    I had some feedback from HummingBird's lead developer. It seems, according to the database, that there're 1743 assets (!!!) . That's why MySQL is running out of memory trying to process all of these files. This can happen when there's something wrong with the file system or HummingBird is not able to run cron tasks to clear up outdated wphb_minify_group post type records.
    In any case, I would recommend doing a full database backup (make sure you don't skip this step, so you can revert in case that something goes wrong), disable minification and try to manually clear all the wphb_minify_group post types.
    You can do that via phpMyAdmin (this is already installed to your server and you can open it via cPanel). Just run this query:

    SELECT * FROM 'ey8a_posts' WHERE 1=1 AND post_type = 'wphb_minify_group';

    Then select all the rows and delete them.
    Reference: https://www.siteground.com/tutorials/phpmyadmin/query/

    Let us know how that goes!
    Warm regards,
    Dimitris

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.