/?s=query send error not found message

Hi – I was reading Yoast and it suggested that I add /?s=query to my site http://waggacitycaravans.com.au/ to see if I am being found – unfortunately I got an error but I cannot see what I am doing wrong as the site has been registered with Google Webmaster tools – is this a problem ? and how do I fix it thanks?

  • Nithin
    • Support Wizard

    Hi Colin,

    Hope you are doing good today. :slight_smile:

    If I'm not mistaken, you meant that when you go to yourWebsiteURL.com/?s=query you get error not found message?

    If yes, that's not an issue. what the above link does is it'll search for the term query in your website, and since your website doesn't have any such term it'll return search not found. Error 404 means page not found, however, the Error 404 – Nothing found message could mislead users, and I suppose that's coming from the search.php template of your theme.

    You could switch to a default WordPress theme, and check whether you still get error 404, if not, it's related to your themes template, and it's by design. Please check the screenshot below, and see how the default WordPress theme would show that search query.

    You can got to yourWebsiteURL.com/?s=elegance ,and see that it's working fine.

    I hope this helps. Please let us know if you still need any further assistance. Have a great weekend. :slight_smile:

    Best Regards,

    Nithin

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.