SSL certificate for subsites

I have a simple positive SSL for my primary domain on my multisite, but none of my subsites are covered. Some of my subsite users are getting messages that their website is "untrusted" when they type in their URL in the address bar (Firefox). I tested and found that Firefox defaults to https:// so of course if the user doesn't know better, they will go to the https:// version of their site and always get the error message.

My current host charges a lot for each additional ssl. Mine would be *.wordsandwriters.com
First question: is there any way to deal with this issue with the type of certificate I have and question two: where do you recommend getting a third-part affordable certificate that would cover unlimited number of subsites?

Thanks, Joe.

  • Rupok

    Hi joejacobson,

    So you want to have your network main site under SSL, but subsites to be under non-SSL or find an affordable wildcard SSL Certificate, right?

    If you take the first approach, then you can do this with our Domain Mapping plugin. After installing and network activating this plugin, please go to Network Dashboard > Settings > Domain Mapping section. There you will find an option called "Force http/https (Only for original domain)". There are two options. Set "No" for "Would you like to force https in login and admin pages" and set "Force HTTP" for "Would you like to force http/https in front-end pages" option. Please check the attached screenshot for reference.

    This will force your subsites to use non-SSL URL.

    Or, you can edit your subsites by going to "Dashboard > My Sites > Network Admin > Sites" section and edit your subsites. When you click on "edit" for any subsite, go to "Info" tab and change the subsite URL from "HTTPS" to "HTTP" and save. This subsite will load under HTTP from now on. You can do this for all of your subsites.

    Or you can buy WildCard SSL Certificate which will work for your main site and all other subdomain subsites. Actually there are lots of companies providing affordable WildCard SSL Certificates. Just search in google with "Cheap WildCard SSL" keywork and you will get hundreds of options. Check those options and select one according to your preference. That will also resolve this issue I believe.

    Please let us know if you have any confusion. We will be glad to help further.

    Have a nice day. Cheers!
    Rupok

  • joejacobson

    Hi Rupok,

    Thanks for your thorough reply. I tried the first option of changing the settings in the plugin, but that didn't help. First, it disabled my main domain https which I need for the shopping cart, and second, if a user types in (for example), https://jeanolsen.com (one of my subsites) in Chrome, they get an error message as shown in the attached screen capture. The same thing happens in Firefox, except with Firefox, the browser by default places a https:// in the address window.

    So, it looks like it doesn't matter what settings are in the Prosite plugin, the browser will override it.

    Looks like I may have to look into a wildcard SSL.

    Thanks, Joe.

  • Nithin

    Hi joejacobson,

    Hope you are doing good today. :slight_smile:

    Setting up a WildCard SSL would be the easiest way, in clearing out the Your connection is not private message, as it would help in setting up your subsites with https.

    If you are still looking to troubleshoot this further, you could enable support access so that we could give a closer look. You can grant access from WPMU DEV > Support > Support Access > Grant Access, or check this manual: http://premium.wpmudev.org/manuals/wpmu-dev-dashboard-enabling-staff-login/

    Please let us know once you enable access, so that we could get this sorted. Have a nice day. :slight_smile:

    Kind Regards,
    Nithin

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.