SSL users cannot access protected content.

We have switched to https today and now nobody gets access to protected pages. I have url restrictions and I have tested page restrictions. Is there a setting I need to change?