Stange code in posts

Hi

I’m not sure if this is a theme issue or something else (in which case this topic ought to be moved) but I’ve developed a stage bit of code on my featured posts on the home page of my site using the Business Feature theme.

Interesting when I go to the actual post it disappears.

The code is {lang: ‘en-GB’} which shows up at the start of each of the posts.

You can see it here:

http://fast-home-business-success.com

UPDATE

The culprit is the Google+1 plugin. There’s an option to choose the language and whichever I select the code relevant to that language shows up. There’s clearly a compatability issue with the Business Feature theme and the Google+1 plugin guys. Any ideas?

Mark

  • Mason
    • DEV MAN’s Sidekick

    Hiya Mark,

    Thanks for letting us know. I haven’t been able to reproduce this in my tests. Can you give us a bit more details. How do you have WP_LANG setup in your wp-config? What other settings are you using in your Google +1 plugin? Are you running any other plugins on this?

    I can see it on your site, but again, haven’t been able to re-create it and I don’t see anything else on your site that would case this. Anything in your server error logs?

    Thanks!

  • wizzer
    • Flash Drive

    Hi

    Sorry for delay in replying – the sun came out and as it's such a rare occurence here in the UK lately I had to go out and see it :slight_smile:

    OK, I've tried deactivating all plugins to see if there's any impact and can't trace it. Only time the code appears seems to be when Google+1 is active. However, I have a stack of plugins active so I won't guarantee 100% there's not a conflict. Do you need to know each plugin?

    The screenshots shows the Google+1 settings. & wp-config – I've not touched wp-config so it will be whatever the default is. This seems to be English so I don't see why there'd be a conflict.

    There's nothing in my error log

    Thanks

  • Mason
    • DEV MAN’s Sidekick

    Hiya wizzer,

    If you’re going to define a separate language within a plugin, you’ll also want to use the define for WPLANG in wp-config.php (they should always match).

    So you should try adding ‘en_GB’ between the quotes in wp-config.

    If you haven’t been defining anything else with the UK language though, I’d just let it default to English.

    If the above doesn’t sort it, there’s most likely a conflict with one of your other plugins and it’s only cropping up with this combination. On a fresh install with only google +1 and this theme I’m not able to reproduce the issue.

    Let us know how it goes for ya.

    Thanks!

  • wizzer
    • Flash Drive

    Hi Mason

    The plugin seems to require a language to be set. By default it showed (English UK) and I didn’t touch this initially. I have never touched WP Config or anything else to use a different language so everything is using default.

    I tried the change to WP Config but that made no difference.

    I then deactivated every plugin one by one and the problem persisted. I then had every plugin deactivated and reactivated JUST the Google+1 plugin. The problem immediately re-occurred. In other words with just the one plugin activated the issue arose.

    It wouldn’t seem therefore that there’s a plugin conflict.

    Any other ideas?

  • Vladislav
    • Dead Eye Dev

    Hello,

    Thank you so much for posting the screenshot, it helped a lot! The problem is that the +1 plugin you’re using isn’t our +1 plugin (settings in our plugin look a bit differently, like this: http://i51.tinypic.com/hvqj5v.png ), which is why we haven’t been able to reproduce the problem.

    If you could please share exactly which plugin you’re using to integrate the +1 button into your site, we’ll have a much better shot at debugging what goes wrong and where.

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.