Stlye picture for Membership plugin

I am using the subscription shortcode but on the second stage of registration at ytango.com, it pushes the picture out. Can I set a z-index so its behind it?

  • 3SixtyEvolve
    • New Recruit

    Hi Satori83

    Greetings from the WPMU DEV Support Team and thank you for using the Membership Plugin.

    I had a look at your website and actually created a test account. On the second page, as you mentioned the right hand picture is not displaying correctly. But I also noticed that the 'Subscribe' buttons for the membership is not showing correctly. Only one is showing at the free membership level (just thought I would bring this under your attention, I was testing in Firefox).

    Z-index might solve the issue with the image not displaying in front, although I would be interested to know what theme you're using for this website. It looks more like there are some theme-plugin interference there.

    Also, a nice reference to z-indexing: http://reference.sitepoint.com/css/z-index

    I would suggest that you first switch to the standard Twenty Eleven WordPress theme and see if you're still having the issues. If it still persist, we'll have to investigate further.

    Looking forward to getting your feedback.

    Have a good day and all the best with setting up Ytango. Looking good so far :slight_smile:

    GinaB

  • satori83
    • Site Builder, Child of Zeus

    I am using a theme called Buddyboss. I did set a z-index to the image, now its fine on the second stage of sign up but not the first! I used:
    #homepage {
    position: relative;
    z-index:0;
    top: -298px;
    right:-450px;
    height: 728px;
    width: 549px;
    }

    All I want is a graphic next to the sign up form. It worked when I had Gravity form but that because it wasnt a staged process. Im no css guru so its tough. I havent gotten to figure out why there is only one button.

  • 3SixtyEvolve
    • New Recruit

    Hi Scott

    Glad you got it sorted out yourself. I was actually going to post you today with some advice, but you beat me too it.

    Can you share how you got it to work? I'm sure there would be a user around one day that might need to fix something similar.

    Again, glad it worked out. If you require any further assistance with any other topic/ plugin, please don't hesitate to be in touch.

    Gina

  • satori83
    • Site Builder, Child of Zeus

    Sure! The problem with the z-index was everytime I tried to set it, the image disappeared. So what I have is the sign up page with this html:

    <div id="sform">[subscriptionform]</div>
    <div id="homepage"></div>

    Then I added the following css to the divs:

    #homepage {
    
    	background:  url('http://ytango.com/wp-content/uploads/2012/02/ytango_home3-e1331265818640.png') no-repeat center scroll;
    	width: 500px;
    	height: 633px;
    	margin-left:500px; 
    
    }
    
    #sform {
    	width: 450px;
    	float: left;
    	padding:10px;
    }

    This defined and styled each div. I always have trouble with background images for some reason...but this did the trick! See here....http://ytango.com

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.