Store in Marketpress

Hi, I have almost cracked Market Press but have two issues

I have put the store page in main menu (products appears underneath it) but when you click on store it just goes a blank screen and says "Index of Store/Parent Directory" How can this be removed? I really want a store link on the homepage that goes direct to the list guide of products

Also, my shopping cart widget, when I have added something, conflicts with the widgets below as it drops down and it all gets jumbled up. I am using the Max Magazine theme. Any suggestions?

Thanks

  • aecnu
    • WP Unicorn

    Greetings tommyg,

    Sorry to see that you are having a struggle with the Market Press plugin.

    Addressing the issues one at a time, lets start with the store page issue.

    You are using short codes to render your store?

    Are your permalinks set to anything but default? Preferable /%postname%/?

    Please reset your permalinks, even is they are set how you want them simply click the save button which indeed resets them.

    Please advise.

    Cheers, Joe

  • Patrick
    • Support Monkey

    Hiya @tommyg

    Welcome to the forums!

    Just saw that blank page. Not good. Has the "Store" page been auto-created on your site?

    If not, go to the "Presentation" tab of your MarketPress settings and click "Save Settings".

    For your menu, you don't need to use the auto-generated "Store" page menu item. You can use the "Custom Links" feature when creating your custom menus to add any link you want.

    Simply copy the URL of the page where you have listed your products, and paste that in the URL field. Enter whatever label you want to appear in your menu for that item, click "Add to Menu" and drag it to where you want it.

    Once these things are fixed, we'll work on getting your sidebar to behave :slight_smile:

    Hope this helps! And thanks for being a member :slight_smile:

  • tommyg
    • Flash Drive

    Hi patrick

    The store page was auto created on my site but came up with same white screen "Index of store/parent directory"

    So I copied lendmeyourliteracy.com/store/products into a custom link as you advised, added to to main menu as "Products" and seems to work fine with a list shown (is there any way to show these as a grid?)

    But am i now missing out on the actual store page?

    I am not using short codes. When I tested adding [mp_store_link] to a page it links straight to the same blank page again

    The second problem is as you can see from screen shot attached, when I add something to basket it conflicts in sidebar. When i empty the cart however it resets fine and there is space underneath (see second screen shot)

    Thanks

  • tommyg
    • Flash Drive

    One more thing, I added a Product Categories widget to the homepage that listed my category but when i clicked on it this came up

    Catchable fatal error: Object of class WP_Error could not be converted to string in /home/lendmey2/public_html/wp-includes/pluggable.php on line 894

    Thanks

  • Patrick
    • Support Monkey

    Hi again @tommyg

    Sorry for the delay in responding lately... we're literally swamped with new members :slight_smile:

    I can see on your site that your permalinks appear OK. But, have you tried refreshing them? Simply set them to anything other that what you have now, and click "Save". Then set them back to what you originally had, and "Save" again. This can often clear things up.

    Also, with a bit of research on our friend Google, it would appear that your theme may be missing a bit of essential code. See a possible solution here for example: http://wordpress.org/support/topic/catchable-fatal-error-object-of-class-wp_error-could-not-be-converted-to-string-11

    As for the sidebar shopping cart issue: I tried to visit your products page but got 404'd so can't add anything to a cart. Have you deactivated things?

  • tommyg
    • Flash Drive

    Hi

    Permalink reset seems to have done the trick for the store, thanks!

    sidebar issue still there, store has been activated, please take a look (im afraid the essential code google research has bamboozled me? - have emailed the theme developer)

    Thanks!

  • aecnu
    • WP Unicorn

    Greetings tommyg,

    It appears this particular topic is now resolved/closed, if you need any further assistance please let us know.

    If it wasn't resolved, or you have any more questions related to this thread, please feel free to post them below including any new symptoms or errors and tick the 'Mark as Not Resolved (re-open)' box below the post area (or else we'll miss it!)

    Thank you for being a WPMU Dev Community Member!

    Cheers, Joe

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.