Strange behaviour with booking using Appointments+

I have a weekly schedule here:

I'm using the following short codes for this page:

[app_schedule worker_id="1"]




However if I click a time slot, I get 2 "spinners" and even though I can make the appointment, as soon as it is confirmed I get another dialog immediately after saying that the time slot is no longer available.

I'm using the Frisco Buddypress theme.

Any clues on this would be appreciated.

  • bongoman

    Thanks Brashell and PC.

    Brashell, the behaviour I was observing was when one person booked a slot (with auto confirmation turned on) — they would click the time slot and then see two ajax spinners — they would then get a dialog saying the appointment was made and then as soon as that was dismissed, another one would popup saying the time slot is taken and to refresh the page and try again.

    PC, I've cleared the cache and am still seeing the behaviour — two spinners and the two dialog boxes one after the other — the appointment is made OK and the correct notification emails are sent but it is confusing.

  • bongoman

    Here's something else that is odd.

    If you look at this page: you will see the schedule for Gary Pike, with app_provider_id=1 in the url

    However the page at which uses the short code [app_schedule worker_id="1"] displays a different schedule!

    So if Gary Pike is worker id 1, why am I seeing 2 different schedules for him? the incorrect one is referenced with the [app_schedule worker_id="1"] short code.

  • PC


    There seems to be some issue with the shortcode. I will need to have a closer look at your site with more details.

    Can you please send me your login details via our secure contact form

    1: Mark the email to my attention

    Attn: PC

    2: Include a link of this thread in the email

    3: Include FTP and WordPress super admin details.

    4: While filling the form, select "I have a different question" from the list.

    Looking forward for a response on this.

    Cheers, PC

  • pxwm

    Hi @PC - I hope you don't mind me chiming in

    Hi @bongoman,

    Reading your post I'm assuming you only have one Service Provider.

    If I'm correct then:-

    If you wish to 'force' the schedule to show for the Service Provider with an ID = 1 then your shortcode should be:-

    [app_schedule worker="1"]

    However this will not 'force' an appointment to be made for this Service Provider.

    To 'force' an appointment for the Service Provider with ID = 1 then you will need to revise the following shortcode:-

    [app_services autorefresh="1" worker="1"]

    I've included the parameter autorefresh="1" as this will autorefresh the page and 'hide' the 'Show Available Times' button and should simplify the process.

    I hope this helps

  • bongoman

    Thanks for the reply Steve — we won't always have one service provider, we will have many — will this change things?

    It will always be the case that we want to present a schedule for one service provider at a time with their availability and to make an appointment with that service provider only.

    Basically, the user will be searching for a service provider they want to work with, only seeing their schedule and only then booking with them.

  • bongoman

    I've added in the new shortcode to the page here:

    but the following issue still occur:

    • I'm still getting 2 progress spinners on the timeslot when the user clicks here.

    • 2 "thank you" dialogs are popped up, one after the other when the user confirms the appointment — it's as if each progress spinner then generates it's own dialog.

    • the appointments are not being set for "Gary Pike" but for the generic "Our Staff" so if Gary logs in, he sees no appointments set with him even though it it is Gary's calendar.

    • we now have a redundant "Please select a service" dropdown — we only offer the 60 min consultation and so this is redundant.

    • the calendar seems completely unusable on mobile

    • Gary is set to not be available on Thursday yet the calendar shows him as available. If you try and make an appointment on Thu, you then get a dialog saying the slot is taken.

    Any assistance on this would be appreciated, at the moment it seems far from workable. The short codes on that page at present are:

    [app_services autorefresh="1" worker="1"]
    [app_schedule worker_id="1"]
  • pxwm

    Hi @bongoman

    Could you try revising the shortcode:-

    From: [app_schedule worker_id="1"]
    To: [app_schedule worker="1"]

    However if I've understood your requirements correctly and you will have a number of 'Service Providers' then try the following:-

    Revise the following shortcodes in your Appointment page:-

    From: [app_services autorefresh="1" worker="1"]
    To: [app_services autorefresh="1"]

    From: [app_schedule worker="1"]
    To: [app_schedule] if you want to display a weekly schedule

    or [app_monthly_schedule] if you want to display a monthly schedule

    Then add the shortcode: [app_service_providers autorefresh="1"] directly after your [app_services autorefresh="1"]

    Then Update the page

    Then Select 'Appointment' and 'Settings'
    Then Select the 'Working Hours' tab
    Then Select the 'no specific provider' and set all the 'Work?' fields to 'No'
    Then Save
    Then Select each 'Service Provider' in turn and set the relevant 'Work?' fields to 'Yes' and the Start and End times and any Breaks if required.
    Save after you have set the Working Hours for each 'Service Provider'

    Now go to your Appointment page and a 'Service' and 'Service Provider' dropdown should be visible.

    The sequence is:-

    Select a 'Service' from the dropdown and the page should refresh automatically
    Then select a 'Service Provider' from the dropdown and the page will refresh automatically.
    It will then display the weekly or monthly schedule for the 'Service Provider' you have selected and show the available dates and times.

    I hope this helps

  • bongoman

    Back again.

    Basically what I am wanting is a dedicated booking page per service provider and am using this page as an example:

    I basically have practitioners setup as buddy press members and a search/browse facility to allow users to narrow down to a practitioner they like the sound of.

    So on that page I don't want users to choose from different providers — I just want them to be able to book "Gary". At this stage I am leaving services out of it to keep it simple and try and narrow down this glitch.

    I've turned off all availability for "no specific provider" and turned on certain days for Gary which is now showing on the calendar on that page. That's all looking good.

    But notice what happens if you try and book — two ajax spinners appear, the confirmation box appears and if you click to confirm, you get told the appointment time is not free!

    So it is this latter behaviour that feels buggy.

    The short codes in use are:

    [app_schedule worker="27"]
  • PC

    Hey there,

    Sorry for having missed your last response on this one. I was away for a long time and had somethings to take care of and could not be here any sooner. Sorry if that caused you any issues.

    Is the issue still there or have you managed to sort this out on another thread or one of our live chat sessions ?

    If not, it seems that it might be caused due to some issue with cache or some settings gone bad.

    Its processing 2 requests in a single click for some reasons and the appointment is getting booked with the first request and for second it says that its not available.

    Is that happening with even the default WordPress theme ? and is that happening with all the service providers ?

    Cheers, PC

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.