Stripe payment update

I want to update for Stripe payment flow as Stripe recommend below:

In 2017, we'll be deprecating some of the older security protocols (TLS 1.0,
TLS 1.1, and SHA-1) used to make connections with Stripe's APIs. I'm reaching
out to give you an early heads up because your Stripe integration might be
impacted.
Here are some of the key upcoming dates:
On January 1, 2017, we'll drop support for TLS 1.0 connections and SHA-1
certificates.
On May 1, 2017, we'll drop support for TLS 1.1 connections.
We've noticed that your Stripe integration appears to be using TLS 1.0, so
you'll want to follow the steps in this upgrade guide [1] to ensure that your
Stripe integration isn't interrupted in the next year.
To be clear, upgrading to TLS 1.2 will generally not involve any changes to
your code, but may require that you update your operating systems, system
packages, or language runtime libraries. (The exact methodology depends on your
technology stack.)
While you'll be required to make these changes to ensure that your Stripe
integration isn't interrupted, I'd like to stress that TLS 1.0, TLS 1.1, and
SHA-1 are widely considered to be dangerously weak and upgrading as early as
possible is an important part of keeping your business secure. If you'd like
more information about the topic, we've written up a blog post [2].
If you have any questions about this change, or need help in upgrading your
systems, please don't hesitate to ask—you can just reply to this email!

Note: I am using Marketpress version 2.9.4.8,
I have tried to update lasted version but the project has many problems, many pages not work ( you can see here: https://dev.videomantis.com)
Please give for me some suggestions. Please response for me here
Thanks very much.

  • Nithin

    Hi Thomas Popp,

    Hope you are doing good today. :slight_smile:

    I want to update for Stripe payment flow as Stripe recommend below:

    This is related to OpenSSL version in your sever, would recommend you to get in touch with your hosting provider, and ask them to upgrade the OpenSSL version, this should fix this notice.

    I have tried to update lasted version but the project has many problems, many pages not work ( you can see here: https://dev.videomantis.com)

    I could notice that the checkout process is not working properly, could you please switch to a default WordPress theme, and check whether you are still having issues.

    If you are still having problems, would recommend you to enable support access, so that we could give a closer look. You can grant access from WPMU DEV > Support > Support Access > Grant Access, or check this manual: http://premium.wpmudev.org/manuals/wpmu-dev-dashboard-enabling-staff-login/

    Please let us know once you enable access, so that we could get this sorted. Have a nice day. :slight_smile:

    Kind Regards,
    Nithin

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.