Stripe Transaction not working

When I try to go through the process of purchasing a site, I get the following message: "The Stripe Token was not generated correctly. Please try again." This happens for both the free and paid purchase. (I am in test mode, by the way.)

Any ideas why?

Thanks.

  • faydra_deon
    • WordPress Warrior

    @warpedmind:

    While you're waiting for a Staff member and/or other member to help you out with this question, try to see if the following discussion gets you where you're trying to go:
    https://premium.wpmudev.org/forums/topic/receiving-an-error-from-stripe-the-stripe-token-was-not-generated-correctly

    That's a discussion started by another member about 5 months ago.

    If it doesn't get you where you're trying to go, I know that a Staff member will be chiming in shortly to help out. They're really good about getting to everyone as quickly as possible. It's just that's it's more of us than there are of them. :o)

    Faydra...

  • warpedmind
    • The Incredible Code Injector

    Thanks Faydra and PC.

    PC, I copied and pasted the keys directly from the stripe website. I double checked and removed a trailing space from the end of each string. I double checked the webhook url and successfully tested that. However, after all this and then testing, I still receive the same error. Can you please advise?

  • PC
    • WPMU DEV Initiate

    Hey there,

    Sorry about missing your last message.

    I would like to have a closer look at this and see what is going on there.

    Can you please send me your login details via our secure contact form

    1: Mark the email to my attention

    Attn: PC

    2: Include a link of this thread in the email

    3: Include FTP and WordPress super admin details.

    4: While filling the form, select "I have a different question" from the list.

    Looking forward for a response on this.

    Cheers, PC

  • David
    • WPMU DEV Initiate

    Hi guys,
    I will be very interested in the outcome to this as I am having the same problem. Seems this issue has been around before and touched on by others in previous threads but never any solution or follow ups posted. This could be the one where it can be solved....I hope :slight_smile:
    Good luck!

  • PC
    • WPMU DEV Initiate

    Hey @warpedmind

    I have just replied to your email seeking some information. The details stopped working can you kindly double check and send them over again ?

    I am trying to replicate it exactly the same way as your site on my lab site.

    Cheers, PC

  • warpedmind
    • The Incredible Code Injector

    Thanks @pc, but that didn't work. :slight_frown: I originally thought the same thing, for I ended up getting rid of trailing spaces originally. But I just got the following error:

    The Stripe Token was not generated correctly. Please try again.

  • warpedmind
    • The Incredible Code Injector

    Weird. I just tried again. The previous time, I selected the Monthly Elite. This time I tried the Annual Pro and got the following:

    Invalid timestamp: must be an integer
    Your subscription has been canceled

    This site should continue to have JWPlanet+ features until December 2, 2013. (** which is today @pc **)

    ...

    Ok, I just retried the Monthly Elite with a different card:

    Your card was declined. Your request was in test mode, but used a non test card. For a list of valid test cards, visit: https://stripe.com/docs/testing.

    I'm guessing this is the correct response? I have no idea, but it looks better. Thoughts?

  • warpedmind
    • The Incredible Code Injector

    Hi @pc,

    Just to update you, I used one of the cc numbers listed on that testing page: https://stripe.com/docs/testing

    I got the following success message: Your subscription was successful! You should be receiving an email receipt shortly.

    That's good news! But I am still uneasy. How do I know this is tested and working properly? Also, in stripe, I tried to "send a test webhook to the webhook endpoint (test-mode only) of your choosing" When I did, sending a charge.succeeded webhook (whatever that means), I got the following error: Test webhook error: 302

    I realize that this is taking place on the Stripe.com website... but isn't this indicating that the website plugin is not working correctly? Can you please help me figure this out. Thanks so much if you can. I'm really lost. Do you guys have some sort of manual on how to test cc functionality before going live? I'm scared, because I have no idea how to thoroughly test this.

  • warpedmind
    • The Incredible Code Injector

    Sorry to bother you again @pc... I just noticed that, even though I supposedly had a successful transaction, when I clicked the link to go to the new blog, it simply took me to the admin area again. I then went to see if a new blog site had been created. Nothing new had been created.

  • warpedmind
    • The Incredible Code Injector

    Hi @PC, I just realized something... you know those rating things by your comments that asks if you were helpful, ok, or not? Well, I of course have always felt you to be very helpful, but, as I was clicking on someone else's feedback, I suddenly fear I might have accidently hit "ok" instead of "helpful". I would imagine that these affect your stats in someway... please look... if it says "ok", that is incorrect and I would like to change it. :slight_smile:

    Anyway, looking forward to your reply regarding my issues here. Thanks so much.

  • PC
    • WPMU DEV Initiate

    Hey there @warpedmind

    Thanks for posting back.

    I just tried it out on my lab site and also see some inconsistent behaviour. Considering Stripe as a beta version on Pro Sites plugin, I would like to run a few more tests to see if I can get this working before I seek advice from Aaron.

    PS : No worries regarding that feedback :slight_smile: You can change whenever you want by marking it as helpful, ok or not hepful depending on how you consider support you received from me :slight_smile:

    PPS : Thanks for sending those updated creds, I am going to use them on my lab site now.

    Cheers, PC

  • PC
    • WPMU DEV Initiate

    Hey Tom,

    I just tested and it works fine for me on my lab site.

    I used the Card as

    6011111111111117
    expiry date : 12 2017
    CVV 123

    Please note that you should not use your own card for testing purpose. Its the test cards which have to be used.

    Can you kindly try again ?

    Cheers, PC

  • warpedmind
    • The Incredible Code Injector

    Thanks @pc. Transactions are going through now!

    But I've noticed something else now. I hope you don't mind if I add it to this thread, since you've been so helpful. (If you'd rather I open a new thread, just let me know.)

    I've made a purchase... then I upgraded it to another package. But everything still indicates that I have my basic rather than premium package. I have confirmed in Stripe that the transaction was accepted... so why is the plugin not updating the package status? Any ideas? (See user "Tom Tom" with sites "Tom Tom Test 1" and "Tom Tom Test 2")

    Thanks

  • PC
    • WPMU DEV Initiate

    Hey there Tom,

    Thanks for posting back.

    While it would suit a new topic better as this has been a long one and originally reported issue was different. I doubt it on IPN issues. How long did you wait for to get this updated ?

    I will surely have a closer look however would be please be so kind to create a new thread and provide a link to that thread here ?

    Cheers, PC

  • warpedmind
    • The Incredible Code Injector

    Ok, I've created a new thread for this new issue: https://premium.wpmudev.org/forums/topic/upgrades-not-being-reflected-but-transaction-shows-up?replies=1#post-562972

    And it's been a solid day since the issue and the test member is still reflecting the basic instead of elite membership that I upgraded to.

    If you could help me with it @pc, I'd really appreciate it! :slight_smile: You've been awesome so far!

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.