Studio Theme does not show blog posts :(

I've tried choosing the posts page in the Reading settings - I created a page called "Blog" and went into the reading settings and set up the posts page to "Blog"... but now, if I click on "Blogs" in the navigation I actually see the page like homepage.

Is there any way to show my posts on page called 'Blog' as I can see in the theme's demo?

Please, help me! I am totally stuck.

  • DavidM
    • DEV MAN’s Mascot

    Hi webinarfm and welcome to WPMU DEV!

    It sounds like you'd just need to select the 'Blog news' page template for that page. Basically when you go to edit that page you'll see the page template selector as illustrated here:

    Could you take a look into that?

    Thanks,
    David

  • webinarfm
    • New Recruit

    Hello!

    I already tried this trick but it did not work for me because this step is don't needed:

    >> I went into the reading settings and set up the posts page to "Blog"

    So after I've return reading settings to default value all became fine.

    Thank you a lot!

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.