Studio Theme - How do I change background color and foreground text on sliding login panel.

Hello,
I just installed the Studio Theme and find it very easy to edit most things. However, I cannot see where to change the background colors of the sliding login panel that comes with Studio. I changed the top Header background color and want the panel to match.
Also, in your Studio Theme Demo you show the text "hello" and "Our community" on the login panel. I don't see where to edit that either.
please advise and thanks!

  • Mason

    Hiya!

    Glad you're digging the Studio theme.

    The options you're talking about aren't editable through the theme options. We've got loads of options in the theme by default but the one's you're referring to would have to be added manually in the CSS and plugin files.

    For the background of the panel, add the background property in your style.css for #panel. Also, you can change the words you're asking about in the the file studio>library>component>panel.php. Just do a search for the words and replace them. There's two references to "Our Community" and one for "Hello".

    Thanks!

  • Mason

    Hiya,

    You've got it exactly right. You should be able to comment out the line in the child's style.css and then create a copy of that folder and your new css file. You can create a "child.css" file here and just implement all custom properties here from bp-default, adminbar, etc.

    Let us know how it goes. If that doesn't do the trick for ya, I may need a link to your site to see what's going on.

    Thanks!

  • bkeller99

    Turns out its not the panel settings. Its actually a tab-1.png along with the right, middle,etc.
    I had one other question that arose from changing the text for the panel. Its a good thing I had another instance of the site open in Google Chrome because Firefox wasn't displaying the changes. I would have beating my head wondering why it wasn't taking. Anyway to the question...do you know a good way to refresh the cache in Firefox? Clearing recent cache doesn't seem to work.
    any insight would be helpful.
    thanks

  • Mason

    Hiya,

    Yeah, I noticed the PNGs as well, but forgot to mention.

    Anyway to the question...do you know a good way to refresh the cache in Firefox? Clearing recent cache doesn't seem to work.

    That's odd. I use Ctrl+Shift+R all the time (or Cmd+Shift+R on mac) and do "hard refreshes" all the time. I haven't seen this be an issue. You working locally on your machine or connecting to a server and making changes there? Sometimes there can be a delay or the cache get's stuck in the DNS (then it's time to flush DNS.
    http://www.tech-faq.com/how-to-flush-dns.html
    Or just use 2 browsers as you were ;D

    Seems to work for me. Thanks!

  • bkeller99

    Thanks Mason,
    Dns getting stuck wouldn't explain Chrome updating right away. I think its something with firefox because I've stopped and started it a couple of times and it still hasn't picked up the change.
    ANyway, the panel thing is not that big a deal but it is curious. The tab is a group of images, easy enough to change, but when you click the tab and it slides down ---that background color doesn't show up in the css file. When I use Web Developer extension in Firefox it lets you make css changes on the fly, but in this case it just makes the tab invisible...I don't think it likes AJAX.
    Anyway I'm at a wall here with the membership plugin. I'm waiting for a response on that message. Trying to import paid users from Amember to Membership so colors are going to have to take a backseat for now.
    Thanks for your support, Mason.