Stumped on where a theme is going caddywhompus on other computers

Not sure if this is something that y'all can help with since it's not a theme or plug in directly from you?

I'm rebuilding my blog (heck, my entire site) because some might recall the WP installation was hopelessly done for, and then unrelated, the server itself crashed. In trying to restore everything, somehow my ex turned my site into Joe's Apartment. To get rid of all the bugs, we had to nuke the entire site from orbit. Only way to be sure. Since I wanted to do a total overhaul anyway, it wasn't a big deal.

I'm working on a new design layout for my blog, using the theme "Jolene". On my Firefox browser, (47.0.1, with the following plugins: Adblock Plus (Last Updated Thurs April 28, 2016), Add Bookmark Here, Copy as Plain Text, Copy Link Text, Easy Copy, FireFTP, Flash Video Downloader, Gmail Notifier, Lazarus, LJ Account Juggler, Personas Plus, RightToClick, Status-4-Evar, TabMixPlus, TabGroupsManager, Web Of Trust) It renders properly.

It renders properly on Chrome, Version 53.0.2785.116 m (64-bit), as well as Edge (which is letting me no longer recoil and hiss and look for holy water whenever a Windows browser pops up now.)

BUT. (you knew that was coming or I wouldn't be here.) My wife, who also has Firefox, and up to date, has only these ad-ons: adblock plus, copy as plain text, copy link text, gmail notifier, LJ account juggler, Right to click, tabmixplus, web of trust. Less than I do.

And I checked the rendering of the site for mobile/tablets, and it should display correctly. But on my Google Nexus tablet using a Dolphin browser, I wound up with the same problem she did.

The problem she had, and the Dolphin had was the left sidebars stretched over the full extent of the page, and the center actual blog entry area was pushed way to the bottom and had no lighter background color and the text was all smushed up together. (She's downstairs on the laptop Skyping with her father. I'm going to have her check the blog on the laptop; either way, I'll get a screencap of how badly borked it renders on her desktop soon.)

I overall like the looks of this, but I still want to tweak it more, which would mean doing some custom CSS, and I don't want to bother with that much if the whole theme needs to just be scrapped because it's not going to work for most people.

And in case it's not even rendering for you... here's how it SHOULD look...

EDIT: Okay, it renders correctly on wife's Firefox on the laptop, and NOW the desktop is behaving for her. Still arguing with my Google Nexus on Dophin, though.

  • Rupok

    Hi Susanne,

    Not sure if this is something that y'all can help with since it's not a theme or plug in directly from you?

    If it's not our plugin or theme, we can't guarantee that we will be able to fix, but definitely we will try to fix that or try to find a workaround for you as long as that's related to WordPress.

    However, regarding your design breaking issue in Dolphin Browser on your Nexus Tab, I tried to regenerate this from my Firefox with all sized of Responsive Design Mode, Chrome with responsive mode, Opera and Safari, but in all browsers, it's showing perfectly.

    I even tried from my iPhone 6S but still same, looking perfect. So I think, you have issue on that specific browser in that specific device. Can you please try clearing all cache and cookies from your dolphin browser and try again? To know how you can do that, you can check this page: http://dolphin.com/9-ways-to-streamline-your-dolphin-browser/ Can you also try from another dolphin browser in another Nexus Tab? Can you try from another network?

    Please let us know how it goes. In the mean time, I'm asking my colleagues who have a Nexus Tab to check your site with Dolphin Browser. If any of them can regenerate the issue on their Tab, I'll update you here.

    I believe clearing cache and cookies will fix this for you. If it doesn't, please let us know. We will do further testing to find out the reason.

    Have a nice day. Cheers!
    Rupok

  • Susanne

    Thanks. My wife loaded the site again to get a screencap for me, and Firefox just batted its eyes innocently at her and went "Error? What error? I see no error here, just a perfectly rendered blog theme. You must be confusing me for another browser." ... ¬_¬ yeah, yeah, we saw what you did there.

    So whatever bizarre freak-out happened, apparently it doesn't want to happen anymore? (Ever have that with a car? Weird noises, go to the mechanic, nothing weird happens? Gah.) As long as this trend of behaving on various browsers keeps up, I'm good. Not much point to a blog site if it can't be read by most people dropping by, y'know?

    I figure it's pretty much case closed. If none of your colleagues can make any of their browsers squeal and freak out when handed the url and everything looks fine, you might as well tick the 'mark as resolved' box.

    Thank you for your help!