Styles are not

Styles are not loading in WPMU DEV > Plugins menu. Conflict with WPide plugin:
https://wordpress.org/plugins/wpide/

  • Lindeni Mahlalela

    Hello Paul

    I hope you are doing great today. I am sorry you are having a problem with one of our plugins and thank you for your patience while we were looking into this.

    The good news is that I was able to isolate the issue and have created a solution for this. The issue is that both plugins use the 'admin_body_class' filter to add CSS classes to the HTML body element which is then later targeted by CSS to provide the layout. The issue is that the WPMU DEV Dashboard does this earlier than the WPide plugin so the latter overrides what the other has done.

    To solve this, since it is the WPMU DEV plugin's page that has the problem, the solution is to apply the filter at a later stage and re-add the CSS classes only if this page is loaded, this way, other pages will not be affected especially the WPide page, it will continue to work.

    Add the following page to a new .php file and upload it to 'wp-content/mu-plugins/wpmudev-wpide-fix.php':

    <?php
    add_filter("admin_body_class", "wpmudev_wpide_body_class", 999, 1);
    
    function wpmudev_wpide_body_class($classes){
        if ( isset( $_GET["page"] ) && $_GET["page"] == "wpmudev-plugins" ) {
            return $classes .= " wpmud wpmud-plugins ";
        }
    }

    If the 'mu-plugins' folder does not exist in the wp-content folder, then simply create it. Alternatively, you can simply download the attached 'wpmud-body-class.zip' file and install it as a regular plugin by uploading it via the "Plugins > Add New" page in your WordPress admin. Last option, but not recommended, would be to copy the above code and paste it in your active theme's 'functions.php' file but this includes the risk of losing this code should your theme get updated - if you choose this method remember to remove the PHP opening tag '<?php' in the code above as the functions file will already have this.

    After adding the code you should just reload the "WPMU DEV > Plugins" page and it should work as it should and the plugins should be displayed correctly.

    I have tested this on both a multisite and a single site install and it worked for me, I hope it works for you too. Please test and let us know if you have any issues or need help adding this code on your site.

    Have a nice day.
    Mahlamusa

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.