Styling stripped out

Hi. I've recently started a trial with WPMUDEV. I've installed a few of the main plug-ins; Dashboard, Defender, Hummingbird, SmartCrawl, Smush Pro and Snapshot. I used Defender to resolve some issues, I also used Snapshot to run a backup before editing my database prefixes.
I've just refreshed my homepage and a lot of the styling seems to have gone missing. Is someone able to help resolve this issue?

Thanks
Wayne

  • Rupok

    Hi Wayne,

    I've just refreshed my homepage and a lot of the styling seems to have gone missing

    I'm so sorry to hear the inconvenience you are having. However, just to make sure that no specific plugin is causing this, can you please do a plugin conflict test? To know more about plugin conflict test, you can check this guide: http://premium.wpmudev.org/manuals/using-wpmu-dev/getting-support/

    Please let us know how it goes. If you can't identify any specific plugin causing this, then I need to check your site configuration. I could tell you better about the issue if I could see it live, check your current configuration and make some tests on your site. Would you mind allowing Support Access so we can have a closer look at this?

    To enable support access you can follow this guide here:
    http://premium.wpmudev.org/manuals/wpmu-dev-dashboard-enabling-staff-login/

    Please confirm here when you are done granting Support Access. I'm looking forward to hearing from you and resolve this issue as soon as possible.

    Have a nice day. Cheers!
    Rupok

  • Nithin

    Hi Wayne,

    Hope you are doing good today. :slight_smile:

    I think it may have something to do with the issues that the Defender plug in 'fixed'. I've enabled Support Access for you guys to have a look.

    Yes, you are right. This is the result of enabling Prevent PHP execution rule in Defender > Hardener. What the plugin does is prevent any PHP scripts from executing, this is to prevent any damage to your system in case a successful attack takes place.

    Your theme basically executes custom CSS in a php file, hence the Defender treats it as an external PHP scripts, and blocks it. I have disabled the Prevent PHP execution, and now your styles are working without any issues.

    Please let us know if you still need any further assistance. Have a nice day. :slight_smile:

    Kind Regards,
    Nithin

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.