Styling the Comment Plus section

Hi

I have comment plus enable together with two add ons:

Custom Comments Template

Social Discussion

My comment area is a mess. Twitter avatars are flying in the top left of the page. I don´t get any styling from Custom Comments Template.

I don´t know what to to make in order to style this.

Any help or guide is appreciated.

I post a link to a page with comments just for you to see.

Thanks

  • Timothy
    • Chief Pigeon

    Hey there.

    Whilst using the Custom Comments Template did you do the following:

    Using the custom template will override your themes default setup. We provide various default styles you can select from. You may also use those CSS styles within your own theme (found here /plugins/comments-plus/css/themes/) or you can simply move lib/forms/wdcp-custom_comments_template.php to your themes folder.

    And:

    Do not load custom comments template styles - my theme already has all the needed styles

    If you check this option, no custom comments template style will be loaded and only the styles coming form your theme shall be applied.
    To change the actual markup of the custom template, copy this file to your theme directory: /home/cowpatn/public_html/wp-content/plugins/comments-plus/lib/forms/wdcp-custom_comments_template.php, then make your changes there

    How does it work when not using custom templates, is it fine then?

    Take care.

  • Timothy
    • Chief Pigeon

    Using the custom comments template you can use your own template, look at the following for an example:

    lib/forms/wdcp-custom_comments_template.php

    You can just move that to your themes folder /themes/theme-name/ and customise it as you wish.

    You can also turn on the plugin CSS styling in favour of using your own.

    And my last question was if it rendered fine when not using the custom styling option?

    Take care.

  • Laura
    • Design Lord, Child of Thor

    Hi Timothy

    Sincerely, I don´t understand what to do.

    How do I turn on the plugin CSS styling in favour of using some presset style ? What is the procedure ? I can´t see any switch to turn on or off.

    If I deactivate the custom style option the comments section is not fine but at least I have all the avatar in the right position.

    I though this custom style option give me some styling, but how?

    Thanks

  • Laura
    • Design Lord, Child of Thor

    Ok Timothy

    I discovered where in the admin pane to turn on or off stylings and I´m fixins some of the styling issues with avatars, etc.

    Now, what I need to understand is what this pluging does. It completly replaces the functions of my template comments.php with wdcp-custom_comments_template.php ?? When yes and when no?

    Thanks

  • Timothy
    • Chief Pigeon

    Now, what I need to understand is what this pluging does.

    The plugin replaces the default commenting of WordPress with options for:

    WordPress (users logged into your WP install aka the normal WP commenting feature)
    Google
    Facebook
    Twitter

    So your users can then comment with any of those.

    Using this:

    wdcp-custom_comments_template.php

    And turning off the plugins CSS allows you to customise the form yourself, to your liking.

    Hope this clarifies.

    Take care.

  • Laura
    • Design Lord, Child of Thor

    Also, I have another doubt.

    Is there any way to show all the comments together and not separated by tabs?

    Actually, the comments made from twitter are just shown in the Twitter tab. The same happen with the comments made from Facebook.

    I would like to get rid of those tabs and show all the comments together.

    How can I do that?

    Thanks

  • Timothy
    • Chief Pigeon

    So what happen with the native file comments.php ?? It works or it does not work if I use wdcp-custom_comments_template.php ?

    The idea of Comments Plus is it replaces the original comment form. So nothing happens to it, the comment field is simply replaced.

    The comments form show in the tabs, the comments are displayed as per your theme for handling normal comment out put. For example my screenshot is Twenty Eleven.

    Thanks.

  • Timothy
    • Chief Pigeon

    Sure it replaces the comment form, you can customise that as you see within the code there.

    Also, could ypu lease check what I posted here:

    https://premium.wpmudev.org/forums/topic/styling-the-comment-plus-section#post-296488

    The comments don't display in the tabs, if they are then there is an issue between the theme and the plugin. Did you include the form there through hooks? Or was it automatic?

    The tabs should only display the comment forms for each method of commenting.

    Take care.

  • Laura
    • Design Lord, Child of Thor

    Hi

    This plugin insert a div called "wdcp-sd-discussion_switcher" before all the comment section. That is the div that display the comments tabbed. I want to get rid of that one. How?

    It is different from the div called "comment-providers" that display the forms for each method of commenting, at the bottom of the comment sections.

    Thanks

  • Laura
    • Design Lord, Child of Thor

    Hi Timothy

    I don´t get what you mean. There is no tab element in wdcp-custom_comments_template.php

    What I want is to get rid of the comment selector tab that appear above the comments. I attach a picture for you to see, the tabs I´m referring to ar marked with an arrow.

    Those tabs separtae comments depending on the source. I don´t need that. I want all the comments to be displayed in order, one below the other, no matter if it is from twitter of if it is from the blog.

    How exactly?

  • Timothy
    • Chief Pigeon

    So in your theme I see you have two lots of those tabs. The ones at the top should not be there.

    So something in the theme must be changing the behaviour. What I was proposing was hooking around the themes current comment form.

    You need to find your comments form in that theme and then put the following before:

    <?php do_action('comment_form_before');?>

    And then after:

    <?php do_action('comment_form_after');?>

    And then from:

    Admin --> Settings --> Comments Plus

    You can set it to use those hooks, this ensures the Comments Plus form gets hooked in correctly.

    Take care.

  • Laura
    • Design Lord, Child of Thor

    Hi

    I did what you said. I located the comment form and I added the hooks, but there is no change at all.

    And I think this is not related with my theme, this is related with the plugin itself because in the admin panel under Comment Plus > Social Discussion there is an option like this:

    Default discussion tab: Facebook , Twitter or Wordpress (See pictured attached)

    So the top TAB separator is controlled by the plugin itself. Could you please check into tthis plugin or ask the developer ?

  • Timothy
    • Chief Pigeon

    The default simply sets the default tab to be on when a page loads.

    That doesn't make the tabs appear twice on a page. As you saw in my Twenty Eleve theme it doesn't happen there. That theme is coded to WordPress standards which is why the hook isn't needed.

    What might be better is if I just take a look for you to fix the issue. If you could send me your credentials again:

    - Mark to my attention
    - Link back to this thread
    - Include FTP access
    - Include admin access

    https://premium.wpmudev.org/contact/

    Thanks.

  • Laura
    • Design Lord, Child of Thor

    Hi Tim

    The TABS at the top at very different in purpose from the TABS at the bottom.

    The TOP tabs only separate the conversations syncronized from the social media when the Social Discussion Add-on is activated

    The BOTOOM Tabs are just comment forms.

    I put my site on the Twenty Eleven theme and yes I didn´t see the TOP Tabs but, I also couldn´t see all the discussions syncronized from social media. For some reason, Twenty Eleven is not showing those TOP tabs but the content inside them is absolutly necessary. I just don´t want the content separated but INTEGRATED in all the comments.

    And yes, it is a functionality of the Social Discussion Add-on. When the addon is activated, I got the TOP tabs. When I deactivate it, the TOP tabs disapear.

    In short and returning to my osirinal question in this respect:

    Is there any way to show all the comments together and not separated by tabs?

    Actually, the comments syncronized from twitter are just shown in the Twitter tab. The same happen with the comments made from Facebook.

    I would like to get rid of those tabs and show all the comments together.

    How can I do that?

    Thanks

  • Mason
    • DEV MAN’s Sidekick

    Hiya,

    Just checking in to see if this ticket is now resolved? As we haven't heard back, I'm hoping it is and am marking it accordingly, but if you have any questions on this in the future, feel free to re-open it and let us know.

    Thanks!

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.