Subdomain Multisite displays 404 when creating new site

After completing the WPMUDEV Multisite masterclass I thought, why not, lets do it. So I've set up 2 Multisites following the tutorial given. Unfortunately I get 404 error after adding a site when trying to visit it on both installs.

  • Nithin
    • Support Wizard

    Hi Fatih,

    Hope you are doing good today. :slight_smile:

    This is really an odd issue, I gave a closer look at the chat notes, and the settings what's mentioned seems to be correct.

    I tried to create a new test subsite, and checked for any console error but wasn't able to notice anything particular. However, could 403 error when loading the new test subsite.

    Normally 404 happens if wildcard subdomains isn't configured, since you have confirmed wildcard is configured correctly, we'll need to give a closer look at the server side to have a better idea.

    Could you please send us your cPanel credentials, so that we could give a closer look.

    You can send credentials by using our secure contact form: https://premium.wpmudev.org/contact/#i-have-a-different-question

    - To Mark to my attention, the subject line should contain only: ATTN: Nithin Ramdas
    -login url
    -FTP credentials (host/username/password)
    -link back to this thread for reference
    -any other relevant urls

    Have a nice day. :slight_smile:

    Kind Regards,
    Nithin

  • Ash
    • WordPress Hacker

    Hello Fatih

    Please check now. Your wildcard was pointed to wrong directory. It was pointing to /public_html/_wildcard_ directory where it should point to /public_html/ directory, where the the wordpress is installed.

    Also, you were having a fatal error from divi icons plugin, so I had to disable that. Now all the subsites are working. I even created a new test site and that worked too.

    Hope it helps! Please feel free to ask more questions if you have any.

    Have a nice day!

    Cheers,
    Ash

  • Fatih
    • WPMU DEV Initiate

    Awesome!!! Thank you for your great support.

    Actually there is one more question I'd like to ask you: How do I setup SSL so that the sites I'm adding don't trigger a browser warning? Normally subdomains get SSL from my hosting, but somehow that does not work with the ones I'm adding to the network.

  • Ash
    • WordPress Hacker

    Hello Fatih

    Actually there is one more question I'd like to ask you: How do I setup SSL so that the sites I'm adding don't trigger a browser warning? Normally subdomains get SSL from my hosting, but somehow that does not work with the ones I'm adding to the network.

    You would need a wildcard SSL certificate to cover all the subdomains using one certificate. If you are not sure about the type of your SSL certificate, you can ask your host. Setting up an SSL certificate actually varies from server to server and it can go in a wrong way. So, it's better to take help from the hosting, they should be able to help you.

    And I have the same issue with the other network fatihkarlidag.biz

    What is the issue? 404 or SSL issue? For 404 issue, please change the directory of wildcard subdomain. If the issue is related to SSL, I hope the above explanation should cover that :slight_smile:

    Hope it helps! Please feel free to ask more questions if you have any.

    Have a nice day!

    Cheers,
    Ash

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.