Subdomains unrelated to Wordpress MU

Hi there!

I'm running a Wordpress Multisite where I've installed a few programs (WHMCS, Integrator 3, etc.) on subdomains. These domains are not related to the WordPress Multisite directory, yet they do communicate with the WordPress installation through a few plugins.

Everything worked fine, but then I wanted to force SSL upon all subdomains. So I purchased a Wildcard SSL.

The SSL connection works great on the website itself. However, not on the subdomains.

The subdomains always tend to go back to the main domain.

WPMU example, a registered WPMU subdomain at the main domain doesn't redirect to the main domain:
https://hmptemplate.hostmijnpagina.nl/ - This works perfectly.

Reseller example, this website has its own WordPress installation:
http://dutchslayers.hostmijnpagina.nl works (www.dutchslayers.nl).
But https://dutchslayers.hostmijnpagina.nl redirects to the WPMU registration page (https://hostmijnpagina.nl/wp-signup.php?new=dutchslayers)

SubDomain example:
The same goes for WHMCS, whereas http://portaal.hostmijnpagina.nl works as intended, but https://portaal.hostmijnpagina.nl redirects to the WPMU home page (This is temporarily the local .htaccess' fault, but it will try to go to the registration page if the file is changed or removed).

I'm using WHM/cPanel on a dedicated server with my own nameservers. So I pretty much have access to anything and on the fly.

Any idea's? Thanks!

  • Sybre Waaijer

    Sure thing Michael, here it is:

    Options -Indexes
    # BEGIN WordPress
    RewriteEngine On
    RewriteBase /
    RewriteRule ^index\.php$ - [L]
    
    # add a trailing slash to /wp-admin
    RewriteRule ^wp-admin$ wp-admin/ [R=301,L]
    
    RewriteCond %{REQUEST_FILENAME} -f [OR]
    RewriteCond %{REQUEST_FILENAME} -d
    RewriteRule ^ - [L]
    RewriteRule ^(wp-(content|admin|includes).*) $1 [L]
    RewriteRule ^(.*\.php)$ $1 [L]
    RewriteRule . index.php [L]
    # END WordPress

    This file is located in the public_html directory, cuddling together with all (sub)domains on the server (the subdomains have their own folder in it, unless it's a WPMU subdomain).

    ----

    For reference, I disabled the .htaccess file in WHMCS, you can now locate WHMCS through a non-secure portal here: http://portaal.hostmijnpagina.nl/whmcs/
    When adding https://, it will redirect to the main domain.
    EDIT: When adding https:// now, it will generate an internal server error. This is with the default WHMCS settings.
    EDIT2: I locked myself out of WHMCS - again :') permanently redirecting to the main domain now when trying to access the admin side.

  • Sybre Waaijer

    I think I found a lead here: even https://www.dutchslayers.nl redirects to https://www.hostmijnpagina.nl

    Better yet (or worse?), even empty domains (not even registered in cPanel!) redirect to the main domain. They are however registered in my DNS settings...
    They all seem to obtain the Wildcard SSL certificate.

    ---

    Edit: I think this problem is related to the server and its shared IP address over all domains - I already ordered a second IP address (I hope this will solve it!). I've contacted my server provider on this one. I will report back within 24 hours :slight_smile:

  • Sybre Waaijer

    Hi there!

    Thanks for your support!

    The dedicated IP address worked out. With some additional changes to prevent conflicts, I'll just leave this here for future reference and for other people whom might face this problem:

    - Do NOT use *.yourdomain.tld in your SSL listing in WHM/cPanel, but install the SSL for each subdomain as a new, e.g. webmail.yourdomain.tld, etc.
    - Use a dedicated IP in cPanel, SNI does not work as intended.

    As WHM (auto)recommends: "We recommend that users manage individual subdomains (e.g., “sample1.hostmijnpagina.nl”, “sample2.hostmijnpagina.nl”) instead of a single wildcard subdomain (e.g., “*.hostmijnpagina.nl”)."

    ----

    I'm still waiting for the DNS to resolve for a wildcard subdomain (subdomains created in WPMU are listed as "not found". Will report back if it works or not (within 48 hours). I hope I will not face the same problem as before....

    I do not know if it's going to be a problem, but in the past, whenever I entered a non-existing domain name at the end of the trailing slash, I got suggested a new WPMU blog, for example:
    1. I enter in hostmijnpagina.nl/example
    2. I got reported back that the domain example I should register the domain example.hostmijnpagina.nl because it's free.

    But now, I get the following:
    1. I enter in hostmijnpagina.nl/example
    2. 404 not found :slight_smile:

    Once more, I'll report back when the DNS resolves.

    In the meantime, I'm going to figure out how to connect WPMU with WHMCS on registration :slight_smile: (Integrator 3 by GoHigherIs doesn't do a fine job with the X theme (THEMECO) :slight_frown:, nor does it allow a lot of customization as promised.)

  • Sybre Waaijer

    DNS has resolved. I'm back to where I started from. Now, at least I know where to problem lies:
    Wildcard subdomain.

    Now - how I'm going to solve this, I haven't gotten a clue...

    In short:
    test.hostmijnpagina.nl generates a CGI error - whether it's https or http. (this is a registered WPMU blog)
    webmail.hostmijnpagina.nl redirects to the registration page (http://) for webmail

    All other domains have been moved to a different IP so they don't conflict anymore when using HTTPS://

    Edit:
    I do have a clue, using subdirectories instead of subdomains and then removing the wildcard subdomain in cPanel.
    Disallowing /* in robots.txt might help for Google - As allowing /myownsubdirectories will help as well, it will be a bit more maintenance though, I think...

    Any idea if this will solve the problem? Or is it still possible with WPMU subdomain blogs?

  • Sybre Waaijer

    Resolved. Thanks for your input guys, lead me to the right track.

    I'll just leave the process here, can be done in (almost) any order:
    1. Turn Proxy Subdomains on in WHM Tweak Settings. This will autogenerate the subdomains (whm.yourdomain.tld, cpanel.yourdomain.tld, webmail.yourdomain.tld, mailautodiscovery.yourdomain.tld, etc...)
    2. Install the wildcard SSL certificate only on the main domain and the server domain (hosting.yourdomain.tld) in WHM. The Proxy Subdomains will auto generate and take over the SSL certificate.
    3. Use a dedicated IP for the main domain (share the IP with the server domain for proxy subdomains).
    4. Do not use WPMU subdomain, rather subdirectory.
    5. Do not add/install a Wildcard subdomain in your WHM/cPanel DNS settings or subdomains. The proxy subdomains will take care of this.
    6. Install your server programs on subdirectories or other websites (with their own SSL certificate) and limit access through .htaccess and robots.txt (from google).
    7. Use WPMUDev WHMCS provisioning (If you get stuck just keep on reading, their documentation is outdated and all still works if you skip a few steps) to connect to WHMCS.
    8. Use WPMUDev WHMCS Integration to wrap your website around the WHMCS interface, works like a charm, even in maintenance mode.
    9. In WHM, turn "Always redirect to SSL" on in Tweak Domains.
    10. Install all other websites on your server on other IP addresses. This excludes the WPMU blogs - I will report back once I've processed an order and blog installation (with domain mapping) if this works out as intended.
    11. Be awesome and have a great day.

    Optional:
    Use http://wordpress.org/plugins/wordpress-https/ if you don't want to fiddle in .htaccess or the php/httpconfig.
    This does not generate any problems (so far :grinning: and removes/resolves any insecure content on the main page, so it will save you a lot of work, especially when it comes down to Google's Fonts (pain in the uhm..).
    Note: Do not tick "remove unsecure content" for new pages, as this will scramble the links between blogs (error on the plugin's side).

    As you can see in the attachment: the desired pages are auto-generated without problems (the 404 pages are desired :wink:) and obtain the certificate without a problem.

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.