Subscribe by Email - domain mapping issue

The subscribe by email plugin is losing the URL for mapped domains (We are using WPMUDev Domain Mapping Plugin as well).

When the subscription email notifications go out for new posts on domain mapped blogs, the URL of the new post in the email is NOT the domain mapped version. It's the original mysite.blognetwork.com. This looks bad and has generated several complaints from our customers already, as to why their URL is showing up incorrectly for their subscribers.

Is this a bug or a setting that we need to configure?

Thanks,
Jennifer

    Kimberly

    Hello Jennifer!

    Joe gave a great explanation on this some time ago:

    This issue I found with the sub domain showing in the URL is directly related to which URL was used to log into the domain to make the post which is then sent to the subscribers.

    If you log into the mapped domain or TLD of the site and make the post then the email comes out using the TLD as expected. i.e. Login using http://mappeddomain.com/wp-login.php

    I found through testing this also affects the permalinks created for the post made therein.

    If logged in to the sub domain permalinks and emails indicate the sub domain, if logged in using the mapped domain as indicated above the permalinks and emails indicate the mapped domain URL.

    Does this help?

    Best,

    Kimberly

    Jennifer

    This is a great explanation but leads to another problem...

    We use the WPMU Dev Domain Mapping Plugin. The settings for that plugin in the Administration mapping section can either be set to "original domain" (our current setting), "mapped domain", or "domain entered by the user".

    We currently have "original domain" selected because we have a network level login that redirects users to their individual blog dashboards upon login.

    See this conversation that we had with Joe about redirecting members to their dashboard. https://premium.wpmudev.org/forums/topic/how-can-i-set-login-redirect-to-send-user-to-his-main-blog-dashboard

    The login redirect works great EXCEPT in the specific situation where:
    1. the blog has a mapped domain
    2. and the domain mapping setting is set to "mapped domain" (sounds like this is what we need to do based on your comments)

    If we do this, it creates a problem...

    When the member authenticates successfully at the network level - he will then be sent to a new login screen for the mapped domain (as if he is not logged in) - he has to login twice! (once to the network and then again to his blog)

    So...

    How do we have a network login AND make the settings on the domain mapping plugin = "mapped domain" without the member having to login twice?