Subscribe by Email not working on a Domain Mapped Subsite

I am in the process process of moving a client's site to my multisite as a mapped domain.
I've been double checking each all the settings to make sure they match to the originals single site as much as possible.

I'm almost done -
The Domain Map is working
The Contact Form 7 is working.

Where I m running into a problem is Subscribe by Email.

Should the Plugin be Network Activated - or just on the Mapped Domain?

I tried both - so I'm not sure what's wrong.

On the previous hosts single site -
under Subscriptions > Settings > General Settings - I had the field "Notification from Sender" set to
no-reply@mappeddomain.com.

If I only have the Plugin Activated on the Mapped Domain there is nowhere to fill in the "Notification from Sender" field - and if I send a test message I get the white-screen of death.

If I have the Plugin Network Activated - the field setting appears under Network Settings and there doesn't seem to be a way to set a different email for the Mapped domain.

Is this Plugin not multisite capable?

Please advise what I should do.

  • James Morris

    Hell Michael,

    I hope you are well today. Subscribe by Email is fully Multisite compatible. So, it sounds like there are some deeper issues on your site that needs attended to.

    There's a couple troubleshooting steps I'd like you to try to see if we can narrow down the cause of this problem.

    First, could you please run a plugin conflict test to eliminate the possibility of a conflict with another plugin?

    Whenever you perform a plugin conflict test, it's always better to do so on a staging site. You can learn how to create a staging site here.

    The simplest way to perform a plugin conflict test:
    * Login to your site via FTP
    * Navigate to wp-content
    * Rename the plugins folder to _plugins
    * Move the plugin folder (ex: membership) you want to test from _plugins to plugins
    * Then, one at a time, move other plugin folders over from _plugins to plugins until the symptom returns

    NOTE: While you are doing this, do not visit WP Admin -> Plugins on your site. This will ensure that your plugins remain active when you copy them back over.

    If that does not lead to a solution, could you please enable WP_DEBUG and provide us with the output of your debug.log file?

    To enable WP_DEBUG, change the following line in your wp-config.php file:

    define('WP_DEBUG', false);

    To this:

    // Enable WP_DEBUG mode
    define( 'WP_DEBUG', true );
    
    // Enable Debug logging to the /wp-content/debug.log file
    define( 'WP_DEBUG_LOG', true );
    
    // Disable display of errors and warnings
    define( 'WP_DEBUG_DISPLAY', false );
    @ini_set( 'display_errors', 0 );

    After you've visited the pages that are causing you problems, please go to wp-content/ on your server via FTP and download the debug.log file to your local computer. Then, open that file with a text editor like notepad (Windows), GEdit (Linux), or TextEdit (Mac). You can then save the file as a .txt file and upload it here as an attachment to your post.

    I look forward to seeing the results of your tests.

    Best regards,

    James Morris

  • mjkessel

    OK - I spent fair amount of time troubleshooting.
    I didn’t create a staging site - but I debugged on a mama pro multisite installation locally.
    (just wondering - will the staging instructions you sent work on a multisite with domain mapping - configured at the root of the primary domain?) I intentionally set this up so I can use the Cloner Staging Site method.

    The conflict seemed to be the HTML Email Template Plugin.
    Once I deactivated it - Subscribe by Email started to work.
    I’m also using the Ultimate Branding Plugin - Not Network Enabled - but only Enabled on each Mapped Domain
    Enabling The HTML Email Template Module there - worked - with out a conflict.

    attached is the debug error I got with the HTML Email Template Plugin for your records.

    Question 2:
    Before I migrated this site - when it was a single install - I used the no-reply@mapped-domain as the Sender Address. Is there a way to still use this email? The setting is only under the Network Admin for the Primary Domain - and I don’t see where I can apply it for a mapped domain (confusing).

  • James Morris

    Hello Michael,

    I'm terrribly sorry for the delay in replying...

    just wondering - will the staging instructions you sent work on a multisite with domain mapping - configured at the root of the primary domain?

    Yes, these instructions should work fine.

    attached is the debug error I got with the HTML Email Template Plugin for your records.

    Thank you. This is quite helpful! :slight_smile:

    Before I migrated this site - when it was a single install - I used the no-reply@mapped-domain as the Sender Address. Is there a way to still use this email?

    If you look at /wp-content/plugins/subscribe-by-email/inc/settings.php, around lines 302-330, you'll see that this should be done automatically for you.

    return array(
    			'from_email' => 'no-reply@' . $base_domain,
    			'keep_logs_for' => 31,
    			'mails_batch_size' => 80
    		);

    As an additional note, you shouldn't need to activate the HTML Email Templates in Ultimate Branding for Subscribe By Email as it has it's own template set.

    Want to override the template files?

    Move any file in /wp-content/plugins/subscribe-by-email/inc/mail-templates/views/ to /wp-content/themes/{current-theme}/subscribe-by-email/ an edit them for changes:

    header.php The code that handles the header styles
    footer.php The code that handles the footer styles
    body.php The code that handles the main body styles
    post.php The code that handles every single post included in the digests

    I hope this clarifies a bit. Let us know if you have any further questions. We're always happy to help! :slight_smile:

    Best regards,

    James Morris

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.