Subscribe by Email plugin missing field and reset to default name

Good morning,

I have the Subscribe by Email activated on several sites. However after upgrading to the latest version (2.7.3) the plugin now is using the root site name instead of the sub blog's name. The one site in particular used to send out as the site Name, but now uses the root site's name. This can be corrected by hand for all sites using this plugin, but seems like a new field was chosen and the old data not brought forward. Resetting to defaults on the site does not help either which would provide a quick fix.

Secondly, the sending email address cannot be configured like it could be before. Therefore new users have the emails being sent from: no-reply@. Existing blogs that were configured are no longer able to have this setting changed (other than digging into the DB). This in turn causes the emails to bounce at our mail server.

Note current WP version is 3.8.2.

Thanks for your thoughts.

Dros

  • Ignacio
    • HummingBird

    Hi @pssdadmin.

    We changed some things in the last version of the plugin. Some settings has been moved to the main network menu under Settings. Those are From Sender, Batch size and Keep Logs for X Days.

    We thought that it makes no sense to let users to manage those settings. It was not an easy desicion but we finally opted for that.

    About the name it seems that in some cases, the upgrade went wrong, I¡ve seen more cases so I'll release a new version, most probably tomorrow, and I'll give you a script that will update the name in all sites automatically (is another little plugin with a few sentences in fact). This script will set the name of the blog as the sender but it won't recover it if the user changed it for a more customized one, sorry.

    Regards. Ignacio.

  • pssdadmin
    • WPMU DEV Initiate

    Hi Ignacio,

    The changes identified make perfect sense and were actually ones that we were hoping for too. Though will admit I am not finding where those changes are as a network admin. I have checked from the Network Admin under Settings and under Plugins (this only let me edit the plugin code). So not sure if I am missing something else. I have also checked as a Network Admin under a blog to try and find the settings but to no avail.

    The script will be perfect. Most of the blogs would not have been customized beyond that so it should work for 99% for the cases.

    Dros

  • Ignacio
    • HummingBird

    Attached to this post you'll see the script.

    You can upload the file to 2 locations:

    1. Upload to your wp-content/plugins folder and Network Activate it
    2. Or upload to your wp-content/mu-plugins folder (if mu-plugins does not exist just create it), this way you won't need to activate it, plugins in that folder will always be activated.

    The script won't do anything until next release so you'll still need to wait until I release a new version of SBE, I'm still trying to fix another bug and will release it ASAP.

    Regards.

  • pennmanor
    • Flash Drive

    I just installed that plugin to update the reply to address. It did show a random users address in the field so I changed it to no-reply for now. The problem is that now all of my blogs have no-reply as the reply to address. I have close to 300 blogs on this site and most folks liked the way it use to be before 2.7.3. That is where the reply to address was the default email address attached to their blog. A site wide setting that changes all of blogs doesn't work Could we get back the original functionality ? Maybe an option at the main site level that says use this address for all blogs or set reply to address to the default user of each blog ? Also,everyday the reply to address is changed to another random blog owners email address so I have to at least change that back to no-reply

  • Dan
    • Site Builder, Child of Zeus

    @Aristath and @Ignacio, what is the status on this?

    I am currently in Beta testing, but about to add a second user, and every user on my network needs to be able to have their own reply-to address for subscribers. If this can't be fixed, how do I downgrade to the last version in which this was possible?

    Thanks guys! Really like the plugin, and hope to be able to use it for my whole network!

  • Ignacio
    • HummingBird

    Hi there.

    We are going to add another option "per site", a reply-to email.

    Email from is needed network wide as it can pass lots of spam filters but we could add a reply-to address for that, however, email from will keep being network wide. It's not usually a good idea to let sites administrators to change that in a network.

    We're releasing a new version where we'll move all the subscribers to the posts table and queries will be optimized a lot so the plugin will work much better and faster. A new release candidate (beta) version of the plugin will be available very soon.

    Sorry for the inconveniences.

    Regards.
    Ignacio.

  • ndic
    • WPMU DEV Initiate

    Hi @Ignacio

    I'm having an issue with my subscribers getting the wrong blog in the From address. The email address is no-reply@blog1.com and it should be no-reply@blog2.com.

    I have installed the sbe-upgrade.php above and the RC1 upgrade and the field for Reply-to email appeared in the Dashboard > Subscriptions > Settings > General Settings. I entered the correct email address but the email still has the wrong blog. I have attached a screenshot.

    I appreciate your help. Thanks!

  • ndic
    • WPMU DEV Initiate

    Hi @Tyler Postle

    Thanks for the quick reply! I am unable to install the upgrade to 2.8RC3 due to a missing file.

    Here is the error:
    require_once(/blah/blah/blah/wp-content/plugins/subscribe-by-email2.8RC3/model/model-network.php): failed to open stream: No such file or directory in /blah/blah/blah/wp-content/plugins/subscribe-by-email2.8RC3/subscribe-by-email.php

    I appreciate your help.

  • ndic
    • WPMU DEV Initiate

    Hi @Ignacio

    Thank you for your quick response! I installed the update to 2.8.1 and the field for Reply-to email is no longer there and the email is still sending with the wrong blog. Exactly like the screenshot above.

    I have also tried changing it in the database inside the incsub_sbe_settings field and it gets changed back to the wrong blog when I submit a test email from the Mail Template tab.

    I appreciate your help on this. Thanks!

  • Ignacio
    • HummingBird

    Hi @ndic.

    Thanks for your response. I'm currently on a trip and I won't be able to fix it until monday but I think I know where the problem is.

    Have you seen any other issue with the new release? Subscribers should have been moved to wp_posts table. Do you see all your subscribers in the list?

    Regards.
    Ignacio

  • Ignacio
    • HummingBird

    Hi @ndic.

    Ok, you need to know something about this new version. If you have a network, some Subscribe By Email Settings will be in the Network admin > Settings > Subscribe By Email (You need to activate SBE in the main blog too).

    We changed the from sender field to network wide because of some problems with spam filters as administrators should not set that field.

    Let me know if it works for you.

    Regards.
    Ignacio.

  • Ignacio
    • HummingBird

    Hi @ndic

    I've added a new filter so you can customize the from sender email. Please, install the attached plugin (is still 2.8.1) first.

    After that, you can create a new mu plugin (for instance, create a new file in wp-content/mu-plugins called subscribe-by-email-hooks.php) and insert the following code:

    add_filter( 'incsub_sbe_from_email', 'sbe_hooks_set_from_email' );
    function sbe_hooks_set_from_email( $current_from_email ) {
    	// You can play with this a lot.
    	// For instance:
    
    	$blog_details = get_blog_details( get_current_blog_id() );
    	$no_reply_email = 'no-reply@' . $blog_details->domain;
    	return $no_reply_email;
    }

    You can set now whatever email you want :slight_smile:.

    Let me know if it works for you or if is better to improve it for the release.

    Regards.
    Ignacio.

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.