Subscribe by email plugin not working on WPMS made by Blog Templates

Any site created by new blog templates on my WPMS install cannot use thie subscreibe by email plugin.

I assume

It works on main domain
It works on new domain without new blog templates (from wpmudev)
Does not work on any other domains.

If it was a plugin main domain has all plugins enabled as on subsites

It does nto work 1.09+

going to try to roll back to earlier verions quick as well.

  • in-mn
    • The Crimson Coder

    Doesn't work :wink:

    I kid, been up all night w sick little ones.

    Doesn't work meaning it will say subscriber added, but not actually ad subscriber.
    Via admin or widget.

    I did have it contingent on supporter. However I have changed that. Deactivated all manually enabled sites. Uninstalled plugin. Tried other versions.

    I did get it to work on a new, non templated site. But none of my old
    (which were all setup by template of a site with plugin enabled)

    I am 95% positive that I do not have any plugins enabled on old sites not enabled on new test (working one) and I have supporter plugins set to auto enable and rest are network enabled.

    There a way to debug this to get you better details?

  • S H Mohanjith
    • Developer

    Subscribe by e-mail only requires one table, please find it's schema bellow. Please replace wp_ with the prefix for your domain.

    CREATE TABLE wp_subscriptions (
      subscription_ID bigint(20) unsigned NOT NULL auto_increment,
      subscription_email TEXT NOT NULL,
      subscription_type varchar(200) NOT NULL,
      subscription_created bigint(20) NOT NULL,
      subscription_note varchar(200) NOT NULL,
      PRIMARY KEY  (subscription_ID)
    ) ENGINE=MyISAM;

    However tables should have been automatically created. Please let us know what you find out. Thanks.

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.