Subscribe by Email shows wrong time zone?

In settings, the default time is set much later than my time zone. My time zone is set properly in WP. Can this be changed? I'm in California, PST.

  • Adam
    • Site Builder, Child of Zeus

    Hi @NerdEnterprises,

    It is possible that your php server time is different which is causing the issue.

    Could you paste this in a new .php file and provide me a link please?

    <?php phpinfo(); ?>

    Kind Regards

    Adam.

  • Ash
    • WordPress Hacker

    Thanks for the screenshot. That makes more sense to me.

    This time is your server time. Please go to /plugins/subscribe-by-email/admin/pages/admin-settings-page.php line no 383:
    replace

    <span class="description"><?php printf( __( 'The time now is %s', INCSUB_SBE_LANG_DOMAIN ), date( $time_format ) ); ?></span>

    with

    <span class="description"><?php printf( __( 'The time now is %s', INCSUB_SBE_LANG_DOMAIN ), date( $time_format, current_time( 'timestamp') ) ); ?></span>

    Please note that, this changes will be lost in next update. So it's worth to note down this changes somewhere and apply again after your updates.

    Hope it helps! Please feel free to ask more question if you have.

    Cheers
    Ash

  • astUtemy
    • New Recruit

    It does, but the emails are not sending. They never have since we've set this up. Here's what we get:

    February 20, 2014 7:01 pm
    Warning: call_user_func_array() expects parameter 1 to be a valid callback, first array member is not a valid class name or object in /home/ericgreenspanps/toolegittoaudit.com/wp-includes/plugin.php on line 199
    153 Details ? Finished

    Then clicking the details, we get:

    Sent Emails

    Warning: call_user_func_array() expects parameter 1 to be a valid callback, first array member is not a valid class name or object in /home/ericgreenspanps/toolegittoaudit.com/wp-includes/plugin.php on line 199
    Digest details

    Date February 20, 2014 7:01 pm
    Status Finished
    Subscribers processed 153
    Still pending 0
    Errors 0
    Users without content to send 153
    Total 153
    Emails details

    eric@7dfour.com User content empty
    seth@nerdenterprises.com User content empty

    Today's didn't do anything at all (meaning no log entry) after setting the date based on the new update of the plugin.

  • Ignacio
    • HummingBird

    Hi @NerdEnterprises

    I just released a new version with the warning fixed, could you test it again?

    However, the sendings problem should be located in another place, so let's check a few things first:

    - What's the digests frequency set in Settings? (immediately, daily or weekly)
    - What kind of posts are you trying to send? (Standard posts, maybe products?)
    - Is that type of post checked in Subscriptions>Settings>Contents?
    - In the subscribers list, what do appear in the "Subscribed to" column?
    - Is the test email working? Subscriptions>Settings>Mail template.

    Regards.
    Ignacio.

  • astUtemy
    • New Recruit

    WPMU plugins are always fabulous, however, like others this plugin lacks any real reporting, tracking or stats. I'd like to be able to view who subscribed/unsubscribed. Is this a feature you would consider? It's quite important.

  • astUtemy
    • New Recruit

    Ignacio/Ashok

    the emails are now sending, however, it only sent two of three from the week. I set it to send a weekly digest a few minutes ago, 10am on a Sunday morning. The one we posted on Friday was not included. The others from earlier in the week were. Any ideas?

    Ashok,
    I'm not sure what screenshot you are referring to.

  • Ash
    • WordPress Hacker

    Hi there

    I was not referring to any screenshot, I understood your issue when you posted the screenshot :slight_smile:

    I just wanted to tell in my last reply that if you please provide the information that @Ignacio asked in his reply, that would be very much helpful for him to troubleshoot the problem :slight_smile:

    Cheers
    Ash

  • Ignacio
    • HummingBird

    Hi @NerdEnterprises.

    There could be some reasons for that.

    - You have not set that post type as content in Settings>Contents tab
    - The post was not published when the digest was sent (only published posts are sent).

    Have you checked that? Also, as Ashok said, it would be great if you answer the questions I posted before.

    Regards.
    Ignacio.

  • Richard
    • WPMU DEV Initiate

    Hi all,

    I'm running version 3.5.3 of the plugin.

    I made the change in the file as mentioned above, /plugins/subscribe-by-email/admin/pages/admin-settings-page.php. It's now line 376

    Changed

    <span class="description"><?php printf( __( 'The time now is %s', INCSUB_SBE_LANG_DOMAIN ), date_i18n( $time_format, current_time( 'timestamp' ) ) ); ?></span>

    to

    <span class="description"><?php printf( __( 'The time now is %s', INCSUB_SBE_LANG_DOMAIN ), date( $time_format ) ); ?></span>

    Hope this helps someone.

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.