"Subscription activation not toggled."

Hello WPMU,

I’m trying to deactivate one of my membership subscriptions and activate another. When I click on the “Deactivate” or “Activate” links underneath the subscription names (located in “Memberships”>”Subscription Plans”:wink: I get the error message “Subscription activation not toggled.” The URL changes to “…/wp-admin/admin.php?page=membershipsubs&msg=8”

I’ve tried upgrading to the latest version of the plugin, I’ve tried deactivating and re-activating the plugin, I tried re-saving my permalink structure and nothing has worked so far. I’m on WP V.3.3.2 as well.

We’re trying to launch our new membership setup and this is really putting a damper on getting things going :slight_frown:

Thanks for your reply back, we’re looking forward to your assistance!


UPDATE: I’ve also tried to delete the subscriptions and can’t…I CAN add a new one, activate, deactivate and delete, but the old subscriptions I have seem to not be functioning correctly. I did “verify tables” inside of the membership plugin and everything said “ok”.

I read the following on this forum page: https://premium.wpmudev.org/forums/topic/membership-plugin-database-interaction-and-admin-panel-permissions

“The admin interface won’t let you delete or deactivate (toggle) subscriptions or levels that have users on them for the obivous reason that you have subscribers on those levels and really should move them to something else before removing their permissions from under them.”

And my membership subscriptions that I’m trying to mess with do show one member using that subscription. So, I tried to remove the user from the subscriptions that I’m messing with…But, this subscription is currently “inactive” and because of that, I’m unable to “Drop” that subscription from this user’s account.

Hmmm…