Subsite admin not seeing plugins.php

Hey everyone, I just want to confirm if there's a bug in my install.

Super admin can see the plugins.php page on subsite admin's dashboard, however, subsite admin cannot.

I've verified that the admin/network/network-settings has enable admin navigation plugins checked.

I did notice when I unchecked it, clicked save, it did not work and was still checked.

If someone could confirm their subsite admins can see plugins.php in wp 3.8 it'd be much appreciated!

  • Vinod Dalvi
    • WP Unicorn

    Hi Paul,

    Thanks for posting on the forums.

    I checked it using WordPress 3.8 on my test site and it worked fine.

    Make sure you have enabled "Enable administration menus" option from the Network Settings from the path.

    Network Admin -> Settings -> Network Settings

    What are you getting if you try to visit the plugins page directly from the following path?

    yoursite.com/wp-admin/plugins.php

    Best Regards,
    Vinod Dalvi

  • Paul
    • Flash Drive

    Hello Vinod,

    Thank you for the response!

    Yes I do have "Enable administration menus" enabled.

    When I try to access plugins.php manually as the subsite-admin it responds user does not have sufficient privilages.

    May be an error on my side.

  • Paul
    • Flash Drive

    Okay I did as you said and found that there was a rogue plugin, I tried before but didn't try clicking the enable plugins menu, I did this time and worked with all plugins deactivated. Couldn't figure out which one it was but all is well now, thank you for your assistance.

    Hope you're having a wonderful day!:slight_smile:
    - Paul

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.