Subsite performance, extenal parent theme resources an minify

Hi,

Is there any way to make a wp subsite perform as cleanly as the main wp site?
A number of things just don't seem to be fixable, such as the child theme reaching for the parent CSS and JS as external references and not available to minify.

What can I do? What am I missing?

Larry

  • Rupok

    Hi Larry,

    Thanks for asking. Are you referring to how you can minify child theme assets in a multisite network? If yes, I think this is possible with Hummingbird.

    For doing this, at first you will need to go to your "Network Dashboard > Hummingbird > Dashboard" and from there, select the "Blog Admins can Minify" option in the Minification box and save settings.

    This will make your subsite admins able to minify their site assets. And this way, they can minify the child theme being used on their subsite.

    Please let us know if this is not what you are looking or if I'm missing anything. We will be glad to help further.

    Have a nice day. Cheers!
    Rupok

  • tishimself

    Hi,

    Correction, I think minify works, but the number of external requests is much higher when a subsite is used. Apparently the parent theme components are considered external resources.

    Maybe the effect on performance is negligible, and I am making too much of trying to reduce the number of HTTP requests to be the same as for the main site that owns the parent themes. But it seems the numbers increase quite a bit.

    Larry

  • Rupok

    Hi Larry,

    You are right. As you are using subdomain subsite, and parent theme resources are coming from the main site URL, those will be considered as external resources. Subdomains are kind of like different domains. That's why you need wildcard SSL Certificate for subdomains, but a regular SSL is good enough for subfolder network.

    But when you minify them with "Combine" enabled, those should be merged with other asset files and Hummingbird will create minified asset files with all resources and thus should reduce the number of HTTP requests unless I'm missing anything. Please check the attached screenshot for reference.

    Can you please try minifying and combining all assets for your subsite and check if that helps? Please let us know how it goes.

    I'm looking forward to hearing from you and resolving this issue as soon as possible.

    Have a nice day. Cheers!
    Rupok

  • tishimself

    Hi,

    I'm sorry I ever mentioned minify, cause that worked from the beginning.

    I only meant that rhe subdomain needed to access external resources.

    I did ask Rocket if they could do something about it, tho I figured it was hopeless. But the response was that there was a way around this. No suggestion as to how, however I think it might not be a problem for subfolded domain references. Not sure why I have always figured subdomains were a better idea than subfolders. I think wp supports both methods.

    Waiting on the rocket support response.

    Larry

    Larry

  • tishimself

    Hi,
    Actually, I can see now that this applies to minify as well as the number of resouces(GTMETRIX).
    Changing the WP-CONTENT subsite URL made a nice improvement.

    Take a look at this change to wp-config:
    //define( 'WP_CONTENT_URL', 'http://MYDOMAIN.COM/wp-content' );
    define( 'CURRENT_SITE_DOMAIN', $_SERVER['HTTP_HOST'] );
    if( 'larry.MYDOMAIN.COM' == CURRENT_SITE_DOMAIN ){
    define( 'WP_CONTENT_URL', 'http://larry.MYDOMAIN.COM/wp-content' );
    }
    else{
    define( 'WP_CONTENT_URL', 'http://MYDOMAIN.COM/wp-content' );

    Am I making more sense now?

    Larry

  • Nithin

    Hi Larry,

    Hope you are doing good today. :slight_smile:

    At the moment, there isn't any out of the box settings in Hummingbird, the solution what you have shown above seems to be a good workaround. Doesn't that work? Is there anything else that we should be looking at it? Since you haven't specified the website link, I'm not sure which website I should be checking in gtmetrix to test number of resource.

    If you still need any further assistance, please advise what I'm missing, and enable support access, so that we could check your website, and if possible also check with the developer for additional feedback.

    Please check this manual on how to enable support access: http://premium.wpmudev.org/manuals/wpmu-dev-dashboard-enabling-staff-login/

    Have a nice day. :slight_smile:

    Best Regards,
    Nithin

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.