Subsite showing an error

The following error shows up in one of my subsites when trying to access any of the admin pages

“The site is experiencing technical difficulties. Please check your site admin email inbox for instructions.”

  • Predrag Dubajic
    • Support

    Hi Thomas,

    It seems that there was some issue with your theme that caused these errors.
    I accessed your files, renamed buddyboss theme folder so it got deactivated, then I restored the name and activated it again from the themes panel.

    After that everything started working again so I believe the theme had some wrong values saved in DB that got updated after re-activation.

    Best regards,
    Predrag

  • Thomas Edgell
    • The Crimson Coder

    Predrag Dubajic

    I appreciate the fact that the error message has disappeared; however, the http:// references to the menu items are still present and not addressed. If you log into the admin area and then look at the page source, do a ctrl “F” and look for http:// you will see 72 references to http:// pointing to the subdomains. It is my belief that when the SSL was installed, the propagation of the new https:// was not completed successfully.

    Please take a look at the tables in the database and make sure that everything is pointed to where it is supposed to be (pointing to the proper https:// reference and/or the proper sub-domain for mapped domains).

    Currently, there are only 2 subdomains that are being domain mapped:

    oncehelped.com – charity.go4successteam.com
    wealthtrainingcommunity.com – community.go4successteam.com

    Thanks for looking into this.

    Tom

  • Adam Czajczyk
    • Support Gorilla

    Hello Thomas Edgell

    however, the http:// references to the menu items are still present and not addressed. If you log into the admin area and then look at the page source, do a ctrl “F” and look for http:// you will see 72 references to http:// pointing to the subdomains. It is my belief that when the SSL was installed, the propagation of the new https:// was not completed successfully.

    I apologize if we missed that. The initial ticket was only about the error so that’s what we focused on. I’m sorry for the misunderstanding.

    If it comes to the “http” issue though, the SSL installation is a server side thing and doesn’t mean that WP is/will be in any way “automatically re-configured” – there’s no such thing like “propagation” of it to all WP configuration. This is something that requires WP install, specifically – sub-sites in this case, to be adjusted manually.

    I checked the install and I do see that most of the sub-sites (that are under sub-domains of the main domain) are still set to use “http” connection. When you try to visit them they are redirected to HTTPS as expected but you are right – they should also be set to use “https://” prefixed addresses.

    It’s the same on any hosting and the way to do this is to edit each site on multisite – via the “Network Admin -> Sites -> All sites -> [Edit] for each site” – and update prefixed there. Alternatively, a WP CLI or just a Better Search Replace plugin could be used but that would require making a replacement (of “http://” prefix with “https://” prefix) in

    – either all the tables – but that would affect literally everything and can also change data that should not be changed
    – or on selected tables – such as e.g. _options table – but that, again, could also affect options that shouldn’t be updated and/or may not also adjust everything.

    That said, editing “Siteurl” and “Home” values in “Settings” tab for each site under “Edit site” (on “network admin -> sites” page) is the recommended way of dealing with that. It can still leave some references in URLs if there were, for example, menu items added as “custom links” or there are any URLs “hardcoded” in theme template files or CSS files – and those would need to be updated manually as well.

    This isn’t actually necessary thing as sites are redirected with 301 (moved permanently) redirect so for search engine indexes it’s fine but if you want to fully remove such references – the way described above is the solution.

    Kind regards,
    Adam

  • Thomas Edgell
    • The Crimson Coder

    Adam Czajczyk

    I hope you are having an amazing day.

    I apologize if we missed that. The initial ticket was only about the error so that’s what we focused on. I’m sorry for the misunderstanding.

    No problem. I am happy that you are willing to continue to find a solution to the root of the challenge vs. a quick fix.

    If it comes to the “http” issue though, the SSL installation is a server-side thing and doesn’t mean that WP is/will be in any way “automatically re-configured” – there’s no such thing like “propagation” of it to all WP configuration. This is something that requires WP install, specifically – sub-sites in this case, to be adjusted manually.

    Sorry, I did not know what to call it. It was my understanding that when the SSL certificate was installed, all of the URL’s would be changed.

    the way to do this is to edit each site on multisite – via the “Network Admin -> Sites -> All sites -> [Edit] for each site” – and update prefixed there.

    I went ahead and made all of the necessary edits to the sites and I have seen a reduced number of 500 errors. I think this process of telling people that they need to check the sub-site settings and update the URL’s should be added to the instructions for new hosting customers.

    Thanks for your help with this challenge.

    Tom

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.