Subsites Not displaying in a Multisite install

Forgive me for double posting this question - I believe i put it under the Multi-DB support forum which is not the proper place. Here is my and upon the recent upgrade to Wordpress 3.3.1 I can no longer "see" these sites. They show in the "Sites" directory and I can access the "Edit" option from there, however, if I try to go to the dashboard of any of these sites I get an Internal Server Error and if I try to visit the sites, I just get a BlueHost page (my hosting service, obviously). What am I missing here? At this point I have deactivated every plugin and only activated the twentyeleven theme. Please, any help would be greatly appreciated!

Thanks,
Isis

  • isis

    Hi Phil,

    Okay, so here is my situation. I have set up a multi-site install using the subdomain set up. I originally did this with Wordpress 3.2 and have since auto-updated to 3.3.1 I recently set up a couple of sub-sites (subdomains) under the Network Admin Panel and one as a user. The main site is IsisAthletics.org and one of the subdomains is Testing.IsisAthletics.org for your reference.
    Under the Network Admin Panel I am able to see these sites under "My Sites", I am able to access the "Edit" portion of those sites from that menu, however if I try to visit the site I get just a standard BlueHost page and if I try to access the dashboard, I get an internal server error.
    After digging around and reading a lot I am curious as to whether or not my .htaccess is set up correctly or if I am missing something else very basic. I set up the wp_config.php exactly as the instructions from Creating a Network in the Codex say ... I am to the point where I think I may just have to go in there and uninstall everything and try from a clean install, but I really would like to avoid that, especially if it is an easy fix.
    What would you advise I do? I have deactivated every plugin and only have the twentyeleven theme activated on everything (main site and subs).

    Thanks!

  • isis

    Bluehost was not helpful. They said I should add some code to my .htaccess

    RewriteCond %{HTTP_HOST} !^www\.example\.com [NC]
    RewriteCond %{HTTP_HOST} ^((www\.)?([a-z]+)\.)example\.com [NC]
    RewriteRule .? http://www.example.com/index.php?username=%3 [L]

    claiming that enabling wildcard subdomains is "an apache configuration, basically should be an htaccess entry"
    So, trusting them, I added those lines to my .htaccess, inserting my domain name in for example and admin for username. This created a 500 error when trying to access my site at all.
    Can anyone see an issue with this code? I think I am gleaning that the wildcard subdomain is not pointed at the right DNS? Perhaps this is just too much for me right now - I have to get moving with building an actual main site, using the tools I registered with WPMU to have. I would still love it if someone is able to help me resolve this issue; the whole point of my business and site is to be able to allow others to start their own site(s) under my main domain.

    Thanks!
    Isis

  • isis

    Hi Phil,

    You are absolutely correct. After going back and forth and back and forth with BlueHost, I FINALLY got this issue resolved.

    #1 - There was no "A Record" in my DNS Zone;
    #2 - When setting up a Wildcard Subdomain, BlueHost's default settings put a Wildcard Folder in the public_html of my account, thus confusing the heck out of Wordpress. Taking that folder out resolved all of the problems.

    Thanks for all the help here - I have to say that I am pretty darn frustrated with BlueHost as they had me chasing butterflies by people in the support area of live support for so long - for someone like me for whom this is not second nature, that has meant hours and hours of researching, reading, uninstalling, re-installing, [rinse, repeat], trying different code, etc.

    In the end, the Support Ticket was answered with a snide air, but it was resolved. I only say this so that others who would like to set up Multisite with BlueHost do not experience the same frustrations as I. Their instructions clearly state to leave the default settings of the wildcard subdomain, when in fact the default settings are incorrect for WP Multisite. Delete the Wildcard folder in the setup process and you are golden.

    Thanks again, Phil, for walking me through the process and for helping me to maintain my stance that this WAS an issue of hosting configuration and not an "unsupported Wordpress issue". That made all the difference!

    Cheers!!

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.