Sufficient Permissions - Won't let me configure

I am trying to configure this plugin, but it returns this message:
You do not have sufficient permissions to access this page.http://www.sbhgc.dreamhosters.com/wp-admin/admin.php?page=membership

I am the site admin. Please help.

  • Patrick

    Hi there @Jamie

    Welcome to WPMU DEV, glad to have you aboard!

    I see in your account here that you auto-installed the latest version of Membership via your WPMU DEV Dashboard. So I tested on a fresh install of WordPress and can access the plugin settings on my test site.

    So either something hiccupped between our server and yours during the install process, or there is a conflict between Membership and another plugin/theme on your site.

    Please first try deactivating and deleting the Membership plugin from your site. Then re-install Membership and try to access the plugin settings.

    If you still cannot access Membership settings, basic troubleshooting protocol should be implemented to locate any possible conflicts. See the diagram at the bottom of this page for more on that:
    https://premium.wpmudev.org/manuals/using-wpmu-dev/getting-support/

    If you would like us to help out with the troubleshooting, please grant support access via your WPMU DEV Dashboard as described here:
    https://premium.wpmudev.org/manuals/wpmu-dev-dashboard-enabling-staff-login/

    We'd be happy to login to your site to help you get this going!

  • Patrick

    Hi again @Jamie

    I've logged into your site now to try to help out. The first thing I've noticed though is that your site is painfully slow to load. :slight_frown:

    The tools at pingdom.com report a time of 24.87 seconds to load the frontpage!
    http://tools.pingdom.com/fpt/#!/c6Zj6W/http://www.sbhgc.dreamhosters.com/

    Also, I see that the max_execution_time is set at the default 30 seconds which, if your site loads so slowly, is definitely going to give you much headaches.

    However, I just tried deleting the Membership plugin, then re-installing it via the WPMU DEV Dashboard and get the same results: insufficient permissions.

    I see though that you have managed to install several other WPMU DEV plugins and can access their settings no problem.

    This leads me to believe there may be an issue with the iThemes Security plugin you have installed that may be interfering with access permissions somehow. Please try temporarily deactivating it, and test again.

    I also see that there are 2 users with the administrator role. So I tried logging into my own test site as a different admin user (with access to the WPMU DEV Dashboard) and still can successfully activate the plugin & access settings.

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.