SumoMe - showing success and subscribe button at same time

Hi there,

For some reason, the sumome functions on my site show both the 'subscribe' and 'success' button at the same time. Photos attached - how should i fix/reset this?

Thanks,
Varun

  • Varun Sharma

    Hi Michelle,

    SumoMe (just like addthis) sort of works across the site. If you visit the page, and then try to close the tab you should see the popup i attached.

    I get this issue from two of their plugins - this popup box and the 'list builder' which you will see if you quickly scroll down a page.

    I'm using sumome on http://www.weednrap.com - no issues there. I think there might be some sort of caching or theme issue?

    Thanks,
    Varun

  • Michelle Shull

    Hey there, Varun!

    I like your sites. :slight_smile:

    This could be a caching or a theme issue, or it could be something we can hide with a little CSS.

    1. To check for caching issues, disable any caching plugin you're using. If your host provides your caching, see if there's a way to flush or delete old cache files so you know you're seeing a live version.

    2. To check for a theme issue, try briefly switching to a default WP theme, which SumoMe was most likely tested with, and see if the issue persisits.

    3. To hide the extra button with CSS, we'll need to know the name of the CSS selector assigned to the superfluous button. You can find this by right clicking the button and choosing "inspect element." A dev panel will appear, and it will show the name of the element you just clicked on. It will start with a . or a #, and, depending on your theme, it may be hard to narrow down what specific elements your targeted element is a child of, or the specific element name you're trying to find. Once you find it, you can play with the CSS right there in your browser. The far right pane of the dev panel will be the CSS styles applied to the selected element. Type this in the top field, whether it has an element name or just says "element"
    display:none;

    If the button goes away, you've found the right thing to target.

    Now, whip open notepad. Copy down the element name.

    .this_fun_element or #this_fun_element, for example.

    Next, put the pieces together:

    .your-element-name {
    display: none;
    }

    And add this to a custom css tool, or the style.css file for a child theme, if you're using one. Some themes also come with a custom CSS tool to add custom styles.

    We can target this more specifically, as well, so the success message is only hidden on pages it shouldn't be, but still shows up when it should. For that, I'd need to get a closer look, so I can find the right set of nested elements to target. (That's harder to explain how to track down, if you're not familiar with CSS.)

    Thanks!

  • Varun Sharma

    Hi there,

    Thanks for the message! Glad you like my sites =)

    I'm not that familiar with css - but i can definitely try it out. Meanwhile - this is the response i got from SumoMe:

    "This is being caused by your own CSS. You will need to audit it.

    You have something in your CSS with an !important rule that's overriding our display:none; flag for the success continue button to only show on the success popup.
    Regards,
    Jamie
    -------"

    Does that point to anything specific i can edit? Or give you control to edit?

    Thanks,
    Varun

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.