sunrise error since wp 3.5 update

since the update for wp/wpmu im now getting this error

Notice: unserialize(): Error at offset 57 of 261 bytes in /home/username/domains/musicgroups.ca/public_html/wp-content/sunrise.php on line 29 Warning: Invalid argument supplied for foreach() in /home/username/domains/musicgroups.ca/public_html/wp-content/sunrise.php on line 51

I downloaded the latest version of both multi-domains and domain mapping.

but this did not fix the issue.

I have other threads which i asked some questions regarding these 2 plugins as well, but i will recap here.

I have 3 domains.
musicgroups.ca
canadiandubstep.ca
canadianhiphop.ca

I want users to be able to choose to create their blogs using all these domains, hence multidomain plugin is needed for.

at the sametime I want only 1 install for wpmu to be at musicgroups.ca

that way musicgroups.ca will be the central hub for everything
canadiandubstep.ca will display only content related to dubstep

and

canadianhiphop.ca only hiphop

now here is the issue

I have a dedicated IP for musicgroups.ca
I use virtualmin as my vps not cpanel

all 3 domains are setup with wildcards
to allow
anyname.musicgroups.ca
anyname.canadiandubstep.ca
anyname.canadianhiphop.ca

again I do not want to have to run 3 seperate wpmu installs.

Now what i though i would be able to do is
make a site via musicgroups.ca

dubstep.musicgroups.ca
and then use domain mapping to point http://www.canadiandubstep.ca to dubstep.musicgroups.ca
and same with http://www.canadianhiphop.ca to hiphop.musicgroups.ca
then in multi-domain add all 3 domains to the list to allow users to use as subdomains.

anyname.musicgroups.ca
anyname.canadiandubstep.ca
anyname.canadianhiphop.ca

that way if someone visited
http://www.musicgroups.ca
http://www.canadiandubstep.ca
http://www.canadianhiphop.ca
then they would see the main sites for each instead of a blank page
this is where im confuzed. If i setup musicgroups.ca as the wpmu and use multidomains plugin to allow them to create
anyname.musicgroups.ca
anyname.canadiandubstep.ca
anyname.canadianhiphop.ca

and left it at that. if someone was to visit the TLD www. what would they see?

Is there anyway or does anyone have any idea how I can accomplish this without installing 3 seperate wpmu installs?

last of all, when im in the dashboard under musicgroups.ca and go to multidomains and add 1 of the domains it shows in the list, but when i refresh the page it disappears, seems that the site wont accept the values.

  • Timothy Bowers

    Hey there.

    last of all, when im in the dashboard under musicgroups.ca and go to multidomains and add 1 of the domains it shows in the list, but when i refresh the page it disappears, seems that the site wont accept the values.

    Can you please provide some screenshots of this?

    You can use Multi Domains so you can sites on any of those.

    You can also create sites within your multisite and then map those domains to them. I've done this on my sandbox install.

    Those sites will still be just sites within one multisite. They won't function as their multisite if this was the aim?

    I wasn't understanding what happens when you mapped those domains to a subsite?

    Could you elaborate further there please.

    You also need to update the sunrise file if you have an old version.

    Thanks.

  • Zyniker

    First, the sunrise.php issues you're seeing: Are you using sunrise.php or the dm_sunrise.php version of the file? If you're using both Domain Mapping and Multi-Domains, you'll need to use the sunrise.php from the Multi-Domains download.

    Second, the root domain issue for the Multi-Domains implementation: You have three domains and you want each one to have a distinct root, correct? This can be accomplished through mapping each addon root domain to a subdomain on the main domain. e.g., if you have example.com, example.net, and example.org and example.com is the main domain, you'll want to map something like mapped-net to example.net and mapped-org to example.org. I'm actually running this setup on a couple of my installations and it has worked without issue.

  • aecnu

    Greetings,

    Knock, Knock - Housekeeping --> Just checking if this issue was eventually resolved in another thread? Or by yourself separately to us? Or by us over email with you? Or using our live support?

    If so, no need to reply, that's great news.

    If not, or you have any more questions related to this thread, please feel free to post them below including any new symptoms or errors and tick the 'Mark as Not Resolved (re-open)' box below the post area (or else we'll miss it!)

    Otherwise, happy days, glad you got it sorted :slight_smile:

    Thank you for being a WPMU DEV Community Member!

    Cheers, Joe

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.