Super Admin user account appears to have been deleted from the database

Hello WP Support Community,

I've been asked to upgrade an old WPMU installation to WP Multisite and so far it has gone well, but I've been unable to log in as the Super Admin user to complete the process.

I checked the 'admin_user_id' record within the 'wp_sitemeta' table, but it was set to 1, and there is no record in the 'wp_users' table with an ID of 1.

I've been doing a bunch of research to try to figure out how to make my user account the Super Admin, but none of the suggested methods have worked.

First, I changed the 'admin_user_id' value to my user ID within the 'wp_sitemeta' table.

Then, I added my user account to the 'site_admins' record of the 'wp_sitemeta' table, being careful to follow the proper format.

Neither of those suggestions has done the trick. Now I can see the "Tools -> Sites" menu option in the admin nav bar, but when I try to access that page I get the "This admin screen is only site admins" message.

Can anybody recommend any additional steps that might be necessary in order to make my user account the Super Admin?

Thank you very much for your help.

Adam

  • pallaisa
    • WPMU DEV Initiate

    Thank you for your response, David.

    There were no records with the IDs 1-4 in the wp_users table.

    Upon your suggestion, I just changed my user ID (and associated wp_usermeta fields) to 1. Also changed the admin_user_id field within the wp_sitemeta table to 1, but I'm still not seeing the "Network Admin" link beneath the "My Sites" option in the admin menu bar.

    I'm really at a loss. I even when so far as to create a brand new WP Multisite installation so I could compare the data related to that site's Super Admin, but I'm still unable to see the "Network Admin" link when I log in.

    Thank you for any further help you can offer.

    Adam

  • pallaisa
    • WPMU DEV Initiate

    Thanks very much for your input, Brad.

    I believe I found the solution this morning, and it appears to be changing the username of the user that I want to make the Super Admin to "admin".

    I know that seems silly, but I've been conducting some tests and that appears to be the key difference. Interestingly, the brand new WP Multisite installation does not have the same requirement - I was able to use any username I wanted as long as the associated fields (see below) are pointing at the correct user. But for this site that began as a WPMU installation and was then upgraded to WP 3.3, I couldn't get this to work until I changed the username to "admin."

    The "associated fields":
    1. wp_sitemeta -> admin_email = email address for the user account that you want to make the Super Admin (check wp_users table)
    2. wp_sitemeta -> admin_user_id = user ID for the user account that you want to make the Super Admin (check wp_users table)
    3. wp_sitemeta -> site_admins = a:1:{i:0;s:5:"admin";} (note that the number 5 corresponds to the number of characters in the username in quotes.)

    Hope that's helpful.

    Adam

  • DavidM
    • DEV MAN’s Mascot

    Many thanks for posting your resolution back here Adam! Really good to know this was an upgrade from the former WPMU version to WP Multisite too, I didn't catch that's what you were referring to in your original post. Thought you just meant an older Multisite version.

    I'm sure this thread will come in handy for those making that upgrade.

    Thanks too for your help, bradpalmore. Sent some points your way for being so helpful. :slight_smile:

  • Mike Price
    • The Incredible Code Injector

    Hey Guys

    I am freaking out! I was playing around on a wordpress single install on a site that is just for testing. I had no idea that it shared database with my main site (thinktaiwan.com) As I was playing around in my fake site I installed a plug in called "Enable Multi-site" to see if it worked as I didnt care if it didn't on my fake site.

    However, not only did it not work it gave me error message stating something in my database wasn't set up properly. Then I went and deactivated the plug in. But now I lost my Super Admin rights in BOTH my sites not just my test site but also in my main site !!

    I dont know what to do because the suggestions in this post didn't help me. Here is what I have in my database:

    admin user id = 1

    site_admins = a:1:{i:0;s:5:"admin";}

    My user name and email is indeed correct.

    Not sure what to do . anyone can help? Thanks!

  • Mike Price
    • The Incredible Code Injector

    Please disregard im such a dummy i figured it out that plug in did work but said it didn't so freaked me out it did bring up a my sites drop down and if i click network admin it allows me to add plugins and shows im super admin ..im new to this sorry!

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.