Super Cache set up, website slow!

Hi, my website is very slow, I optimized my photos, and downloaded Super Cache plugin, set it up but when I try to do a speed test for http://www.freektopia.com shows Leverage browser caching (0). And a bunch of files that says (expiration not specified). Would you please help me to fix it?

  • Nahid
    • Tech Support

    Hi Erika !

    Hope you are having a great day!

    I’m feeling sorry about the matter that you’re having problems with your site. In this situation, I highly recommend you to initiate the Hummingbird plugin which is already installed on your site and enable all the features like Browser Caching, Minification and Gzip Compression. I’d also recommend not using WP Super Cache while using Hummingbird. Moreover, initiate a Performance Report test and Hummingbird will show you what to improve to enhance the speed on your site.

    Hope this helps. Let me know if you need any further assistance regarding this. Thanks!

    Best,

    Nahid.

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.